<!DOCTYPE html>
<!--[if IE 9]><html lang="en" class="ie9"><![endif]-->
<html lang="en" dir="ltr">
<head>
<script src="/cdn-cgi/apps/head/x54TqLdHL-_Odnw89NmF9-WSzjw.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PGPJTQ2');</script>
<script defer src="https://www.googleoptimize.com/optimize.js?id=OPT-P4KBHDZ"></script>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="robots" content="index, follow">
<meta name="robots" content="max-image-preview:large">
<meta name="robots" content="max-video-preview:0">
<title>Man kills wife and jumps into a well in Nakuru | Nation</title>
<meta name="description" content="
The suspect slit the throat of his 20-year-old wife as their two-year-old daughter watched.">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344"
},
"name": "Man kills wife and jumps into a well in Nakuru ",
"headline": "Man kills wife and jumps into a well in Nakuru ",
"description": "<p>The suspect slit the throat of his 20-year-old wife as their two-year-old daughter watched.<\/p>",
"image": [
"https://nation.africa/resource/image/3944334/landscape_ratio16x9/1600/900/3096365aff87903b60052dd3c6552346/SW/new-content-item.gif",
"https://nation.africa/resource/image/3944334/landscape_ratio3x2/1620/1080/2f77f69457a05f6fc003c6127cd9d34e/GF/new-content-item.gif",
"https://nation.africa/resource/image/3944334/portrait_ratio1x1/1600/1600/5a0bddc0076feded800a4a9d3cdab06/UJ/new-content-item.gif"
],
"datePublished": "2022-09-10T17:16:42Z",
"dateModified": "2022-09-10T17:16:42Z",
"author": [
{ "@type": "Person",
"name": "John Njoroge",
"url": "https://nation.africa/kenya/john-njoroge-6378"
}
],
"publisher": {
"@type": "Organization",
"name": "Nation",
"logo": {
"@type": "ImageObject",
"url": "https://nation.africa/resource/crblob/1909958/2d96fc16039969eac48a6e8f3e055af2/structured-data-logo-png-data.png",
"width":242,
"height":60
}
} }
</script>
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Home",
"item": "https://nation.africa/kenya"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "Counties",
"item": "https://nation.africa/kenya/counties"
}
,
{
"@type": "ListItem",
"position": 3,
"name": "Nakuru",
"item": "https://nation.africa/kenya/counties/nakuru"
}
]
}
</script>
<meta property="og:site_name" content="Nation" />
<meta property="og:type" content="article" />
<meta property="og:article:published_time" content="2022-09-10T17:16:42Z" />
<meta property="og:title" content="Man kills wife and jumps into a well in Nakuru " />
<meta property="og:description" content="
The suspect slit the throat of his 20-year-old wife as their two-year-old daughter watched.">
<meta property="og:url" content="https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344" />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:image" content="https://nation.africa/resource/image/3944334/landscape_ratio3x2/1200/800/2f77f69457a05f6fc003c6127cd9d34e/Lq/new-content-item.gif" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="fb:app_id" content="174023979648743" />
<meta name="twitter:site" content="@dailynation">
<meta name="twitter:card" content="summary_large_image"> <link rel="canonical" href="https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344">
<link rel="alternate" type="application/rss+xml" href="https://nation.africa/kenya/rss.xml" />
<meta name="keywords" content="murder, Kuresoi,James Ademba ,Mawingu village in Kuresoi North,Man kills wife">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#303030">
<meta name="msapplication-TileColor" content="#ffc40d">
<meta name="theme-color" content="#ffffff">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<link rel="dns-prefetch" href="https://ev.nation.africa" />
<link rel="preconnect" href="https://ev.nation.africa" />
<link rel="dns-prefetch" href="https://scripts.nation.africa" />
<link rel="preconnect" href="https://scripts.nation.africa" />
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<link rel="preload" href="/resource/crblob/491076/8f26773838fb46720f8eee321565ae9c/morion-regular-woff2-data.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/resource/crblob/491082/db592c09b66baa562172b62cac699422/morion-semibold-woff2-data.woff2" as="font" type="font/woff2" crossorigin>
<style>
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 400;
font-display: fallback;
src: local('Roboto'), local('Roboto-Regular'),
url(/resource/crblob/491098/314b3e27a8fc4d780a703b8c6d60eb2e/roboto-regular-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491096/396f61f2524c1a087da7fe4cf6554302/roboto-regular-woff-data.woff) format('woff'),
url(/resource/crblob/491094/84a6341fddcb66cd50fbd315345d9a79/roboto-regular-ttf-data.ttf) format('ttf');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 500;
font-display: fallback;
src: local('Roboto Medium'), local('Roboto-Medium'),
url(/resource/crblob/491092/dcc5e5d97b52622a8acca0d909ab2e27/roboto-medium-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491090/1e49e636e65523052023a5500a51d168/roboto-medium-woff-data.woff) format('woff'),
url(/resource/crblob/491088/b5f1f1704739a86b2300b6e6258ec7ff/roboto-medium-ttf-data.ttf) format('ttf');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 700;
font-display: fallback;
src: local('Roboto Bold'), local('Roboto-Bold'),
url(/resource/crblob/1909918/e5f93140b1b696f3b64ab1e978eb8a92/roboto-bold-woff2-data.woff2) format('woff2'),
url(/resource/crblob/1909916/3eba6b17da134b2434afb8ad6d2c83a4/roboto-bold-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: italic;
font-weight: 400;
font-display: fallback;
src: local('Roboto Italic'), local('Roboto-Italic'),
url(/resource/crblob/491086/c20ba07e455c114af36596dbe6c7eb51/roboto-italic-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491084/5b17397b930cee50ab6c47fd10641c6f/roboto-italic-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: italic;
font-weight: 700;
font-display: fallback;
src: local('Roboto Bold Italic'), local('Roboto-BoldItalic'),
url(/resource/crblob/1909922/f13d361ffda533c07c9a3df7c140c61c/roboto-bolditalic-woff2-data.woff2) format('woff2'),
url(/resource/crblob/1909920/f7308fd720d9f134b6c3b749b90d2edf/roboto-bolditalic-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Morion";
font-style: normal;
font-weight: 300;
font-display: fallback;
src: url(/resource/crblob/1905440/d98f82389286b2e51bb541e2e1094c8e/morion-light-woff2-data.woff2) format("woff2"),
url(/resource/crblob/1905438/9e36b3c52b6e9ce720c63718506804ff/morion-light-woff-data.woff) format("woff");
}
@font-face {
font-family: "Morion";
font-style: normal;
font-weight: 400;
font-display: fallback;
src: url(/resource/crblob/491076/8f26773838fb46720f8eee321565ae9c/morion-regular-woff2-data.woff2) format("woff2"),
url(/resource/crblob/491074/d3d0f9d8049e5cd34b83418007cfd551/morion-regular-woff-data.woff) format("woff"),
url(/resource/crblob/491072/f527ba223329157953b58091c798640e/morion-regular-ttf-data.ttf) format("truetype");
}
@font-face {
font-family: "Morion";
font-weight: 600;
font-display: fallback;
src: url(/resource/crblob/491082/db592c09b66baa562172b62cac699422/morion-semibold-woff2-data.woff2) format("woff2"),
url(/resource/crblob/491080/4b3380c8a84bfbc97119f89918051b90/morion-semibold-woff-data.woff) format("woff"),
url(/resource/crblob/491078/19f56eb45799e6468b58e3207185344a/morion-semibold-ttf-data.ttf) format("truetype");
}
@font-face {
font-family: "Morion";
font-weight: 600;
font-style: italic;
font-display: fallback;
src: url(/resource/crblob/1337618/950d6833f150399efafa7f7783d2176a/morion-semibolditalic-woff2-data.woff2) format("woff2"),
url(/resource/crblob/1337616/3394fd8e0b9b830296cf395bddc1586d/morion-semibolditalic-woff-data.woff) format("woff"),
url(/resource/crblob/1337614/8fc6226dcb8da45c46665b68afc4bcd1/morion-semibolditalic-ttf-data.ttf) format("truetype");
}
</style>
<link href="/resource/themes/nation-2020/css/nation-2020-491114-152.css" rel="stylesheet">
<link rel="stylesheet" href="/resource/themes/nation-2020/css/ev-widgets.min-653026-2.css" media="print" onload="this.media='all'">
<style>
.color-set-color-1 {
background: #B9002D;
color: #FFFFFF;
}
.color-set-color-2 {
background: #E00026;
color: #FFFFFF;
}
.color-set-color-3 {
background: #FF415D;
color: #000000;
}
.color-set-color-4 {
background: #FF415D;
color: #000000;
}
.color-set-color-5 {
background: #F5F5F5;
color: #000000;
}
.color-set-color-6 {
background: #FFC3CA;
color: #000000;
}
.color-set-color-7 {
background: #F0F0F0;
color: #000000;
}
.color-set-color-8 {
background: #F8F8F8;
color: #000000;
}
.color-set-color-9 {
background: #FFC3CA;
color: #000000;
}
.color-set-color-10 {
background: #FFC3CA;
color: #000000;
}
/* Styling exceptions for Evolok widgets. Needed because we have no control over their HTML so we can't rely on adding classes like elsewhere. */
/* Paywall button */
.ev-modals .ev-open-modal-paywall-REQUIRE_ENTITLEMENT .ev-button-wrapper .btn,
.ev-modals .ev-open-modal-paywall-REQUIRE_LOGIN_WITH_ENTITLEMENT .ev-button-wrapper .btn {
background-color: #E00026;
color: #FFFFFF;
}
</style>
<script>
var icons = new XMLHttpRequest();
icons.open("GET", "/resource/crblob/499920/3a9b76b3474d42bdf43c1be41bb1952e/icons-svg-data.svg");
icons.send();
icons.onload = function () {
var d = document.createElement("div");
d.innerHTML = icons.responseText;
d.style = "display: none";
document.body.insertBefore(d, document.body.childNodes[0]);
}
</script>
<script>
window.googletag = window.googletag || {cmd: []};
window.windowInnerWidth = window.innerWidth;
window.adDesktopBreakPoint = 1000;
window.adSlots = {};
function shouldRenderAd(isMobileAd) {
return (window.windowInnerWidth <= window.adDesktopBreakPoint && isMobileAd) ||
(window.windowInnerWidth > window.adDesktopBreakPoint && !isMobileAd);
}
googletag.cmd.push(function() {
window.bk_dfp_integration = window.bk_dfp_integration || {};
window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {};
if (typeof bk_dfp_integration.functions.sendDfp === "function") {
bk_dfp_integration.functions.sendDfp();
}
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
if (window.location.pathname.split( '/' )[2]) {
googletag.pubads().setTargeting('url1', window.location.pathname.split( '/' )[2]);
}
if (window.location.pathname.split( '/' )[3]) {
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[3]);
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-1'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-1", [[320,50], [320,100], [300, 250]], "mobile-article-ad-1")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-1'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-1", [[728,90], [970,90], [300, 250]], "desktop-article-ad-1")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-2'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-2", [[320,50], [320,100], [300, 250]], "mobile-article-ad-2")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-2'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-2", [[728,90], [970,90], [300, 250]], "desktop-article-ad-2")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-3'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-3", [[728,90], [970,90], [300, 250]], "desktop-article-ad-3")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-3'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-3", [[320,50], [320,100], [300, 250]], "mobile-article-ad-3")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-above-navigation'] = googletag
.defineSlot("/1010816/Z-DN-728x90-ArticleTop", [[728,90], [970,90]], "desktop-article-above-navigation")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-top'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-Article-Strip", [[320,50], [320,100]], "mobile-article-ad-top")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
googletag
.defineOutOfPageSlot('/1010816/Z-DN-RoadBlock','div-gpt-ad-1600501942202-0')
.addService(googletag.pubads());
googletag.enableServices();
});
</script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
</head><body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PGPJTQ2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id='div-gpt-ad-1600501942202-0' style="position: absolute; top: 0;">
<script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600501942202-0'); });
</script>
</div>
<section class="page-content detail-content">
<header class="page-grid-header">
<header data-page-header="true" class="page-header">
<div class="page-header_ad color-set-color-1" data-page-header-ad="true">
</div>
<nav class="main-nav color-set-color-1" data-main-nav="true">
<div class="grid-container">
<div class="main-nav_buttons">
<button class="main-nav_menu-btn" data="open-menu" aria-haspopup="true" aria-controls="menu" aria-expanded="false" aria-label="Toggle menu">
<svg class="icon-menu-button" aria-hidden="true" focusable="false">
<use xlink:href="#icon-menu-button"></use>
</svg>
<svg class="icon-close" aria-hidden="true" focusable="false">
<use xlink:href="#icon-close"></use>
</svg>
<span class="main-nav_btn-close-text">Close</span>
<span class="main-nav_btn-menu-text">Menu</span>
</button>
</div>
<div class="main-nav_ePaper">
<span><a href="https://epaper.nation.africa/ke" target="_blank" rel="noopener">ePaper</a></span>
</div>
<div class="main-nav_editions">
<button class="main-nav_editions-label" data="editions-toggle" aria-haspopup="true" aria-controls="editions-toggle" aria-expanded="false" aria-label="Editions Toggle">
Kenya Edition
<svg class="icon-arrow-down" aria-hidden="true" focusable="false">
<use xlink:href="#icon-arrow-down"></use>
</svg>
</button>
<div class="main-nav_editions-list-wrapper">
<ul class="main-nav_editions-list color-set-color-3" data="editions-list">
<li><a href="https://nation.africa/africa">Africa Edition</a></li>
<li><a href="https://www.monitor.co.ug/uganda">Uganda Edition</a></li>
</ul>
</div>
</div>
<h2 class="logo">
<a href="/kenya" aria-label="Homepage">
<svg class="logo-svg" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 146 30">
<path fill-rule="evenodd" d="M108.648553,27.0221865 C103.845659,28.8163987 97.9344051,24.8691318 95.4446945,18.2054662 C92.9550804,11.540836 94.8282958,4.68424437 99.6302251,2.89003215 C104.432154,1.09572347 110.344373,5.04308682 112.83418,11.7066559 C115.323794,18.3713826 113.449518,25.2279743 108.648553,27.0221865 M104.138907,0 C112.130868,0 118.609325,6.69646302 118.609325,14.9565916 C118.609325,23.2157556 112.130868,29.9122186 104.138907,29.9122186 C96.14791,29.9122186 89.6694534,23.2157556 89.6694534,14.9565916 C89.6694534,6.69646302 96.14791,0 104.138907,0 Z M126.807698,0.490987138 L143.688727,21.2444277 L143.697987,0.507578778 L145.859145,0.507578778 L145.859145,29.438865 L142.724096,29.438865 L125.843068,8.68436334 L125.843164,29.4464855 L123.67265,29.438865 L123.67265,0.490987138 L126.807698,0.490987138 Z M7.09228296,0.478446945 L22.1453376,19.060119 L22.1453376,3.33095498 L20.2160772,0.973302251 L20.2160772,0.490987138 L26.2450161,0.490987138 L26.2450161,0.973302251 L24.3157556,3.33095498 L24.3157556,29.4298939 L22.8688103,29.4298939 L4.34974277,6.53053698 L4.29967846,6.46301286 L4.29967846,26.5900225 L6.22893891,28.9475788 L6.22893891,29.4298939 L0.2,29.4298939 L0.2,28.9475788 L2.12926045,26.5900225 L2.12926045,3.55667846 L0.2,0.973302251 L0.2,0.490987138 L7.09228296,0.478446945 Z M76.4057878,0.477491961 L76.4057878,5.55530547 L66.2771704,5.55530547 L66.2771704,26.5900322 L68.2064309,28.9475884 L68.2064309,29.4299035 L62.177492,29.4299035 L62.177492,28.9475884 L64.1067524,26.5900322 L64.1067524,5.55530547 L53.978135,5.55530547 L53.978135,0.477491961 L76.4057878,0.477491961 Z M43.1260064,0.475562701 L53.9780965,29.4299035 L48.1903151,29.4299035 L45.2068103,21.4717042 L34.0362958,21.4717042 L31.0681286,29.4299035 L31.0681286,29.4212219 L28.6565531,29.4212219 L38.4118585,3.34533762 L39.4836592,0.479421222 L41.8681286,0.477491961 L43.1260064,0.475562701 Z M84.3638907,0.490996785 L84.3639871,29.4221865 L82.1935691,29.4221865 L82.1935691,0.490996785 L84.3638907,0.490996785 Z M39.6080965,6.53633441 L34.9362958,19.0601286 L44.3029518,19.0601286 L39.6080965,6.53633441 Z" />
</svg>
</a>
</h2>
<div class="main-nav_account">
<a href="/kenya/search" class="main-nav_search-button" aria-label="Search page">
<svg class="icon-search" aria-hidden="true" focusable="false">
<use xlink:href="#icon-search"></use>
</svg>
<span>Search</span>
</a>
<div class="account-menu" data="account-menu">
<a href="/kenya/account/signin?redirect_to=https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344" type="button" class="account-menu_login-btn" data="log-in">
<ev-em-profile-when state="LoggedOut">
<span class="profile-btn">
<span class="profile-btn_name">Log in</span>
<span class="profile-btn_icon color-set-color-3">
<svg class="icon-user" aria-hidden="true" focusable="false">
<use xlink:href="#icon-user"></use>
</svg>
</span>
</span>
</ev-em-profile-when>
</a>
<button class="account-menu_button" data="toggle-account-menu" aria-haspopup="true" aria-controls="account-menu" aria-expanded="false" aria-label="Open account menu">
<ev-em-profile-when state="LoggedIn" getProfileEnable="true">
<span class="profile-btn">
<span class="profile-btn_name hidden" data="profile-btn_name">
user.name
</span>
<span class="profile-btn_name hidden" data="profile-btn_email">
user.email
</span>
<span class="profile-btn_icon color-set-color-3">
<svg class="icon-user" aria-hidden="true" focusable="false">
<use xlink:href="#icon-user"></use>
</svg>
</span>
</span>
</ev-em-profile-when>
<a href="/kenya/account/signup?redirect_to=https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344" type="button" class="account-menu_login-btn" data="sign-up">
<ev-em-profile-when state="LoggedOut">
<span class="default-btn color-set-color-3">
Sign up
</span>
</ev-em-profile-when>
</a>
</button>
<nav id="account-menu" class="account-menu_popup">
<svg xmlns="http://www.w3.org/2000/svg" width="30" height="15" viewBox="0 0 30 15" class="account-menu_popup-triangle">
<path fill="#F8F8F8" fill-rule="evenodd" d="M1327,49 C1327,59 1332,64 1342,64 L1312,64 C1322,64 1327,59 1327,49 Z" transform="translate(-1312 -49)" />
</svg>
<div class="account-menu_popup-inner">
<ev-profile>
<ev-profile-when state="available">
<a href="/kenya/account" class="account-menu_popup-header">My account</a>
<ul>
<li>
<a href="/kenya/account#details" class="account-menu_popup-link">Personal details</a>
</li>
<li>
<a href="/kenya/account#password" class="account-menu_popup-link">Change password</a>
</li>
<li>
<a href="/kenya/account#purchases" class="account-menu_popup-link">Purchases</a>
</li>
<li>
<a href="/kenya/account#referral" class="account-menu_popup-link">Refer a friend</a>
</li>
<li>
<a href="/kenya/subscribe" class="account-menu_popup-link" data="gift-subscription">
Gift a subscription
</a>
</li>
<li>
<button class="account-menu_popup-link" data="sign-out">Sign out</button>
</li>
</ul>
</ev-profile-when>
</ev-profile>
</div>
</nav>
</div> </div>
</div>
</nav>
<nav class="sub-nav color-set-color-2" data-sub-nav="true">
<div class="grid-container">
<h3 class="sub-nav_section-title" data-sub-nav-header="true">
<a href="/kenya/counties">
<span class="sub-nav_section-title-desktop">Counties</span>
<span class="sub-nav_section-title-mobile">
Nakuru
</span>
</a>
</h3>
<ul class="sub-nav_link-list" data-sub-nav-items="true">
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/nairobi-metro">Nairobi Metro</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/coast">Coast</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/mountain">Mountain</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/lake-region">Lake Region</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/rift-valley">Rift Valley</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/northern">Northern</a>
</li>
<li class="sub-nav_link-list-item invisible">
<button data="open-menu" aria-haspopup="true" aria-controls="menu" aria-expanded="false">
<svg class="icon-more-link" aria-hidden="true" focusable="false">
<use xlink:href="#icon-more-link"></use>
</svg>
<span>More</span>
</button>
</li>
</ul>
</div>
</nav>
<nav class="mega-menu" data-mega-menu="true" id="menu">
<section class="mega-menu_section clearfix color-set-color-8">
<div class="grid-container">
<div class="col-1-1">
<div class="mega-menu_search">
<a href="/kenya/search" class="mega-menu_search-button" aria-label="Search page">
<svg class="icon-search" aria-hidden="true" focusable="false">
<use xlink:href="#icon-search"></use>
</svg>
<span>Search</span>
</a>
</div>
</div>
<nav role="navigation" aria-label="Site index" class="categories-nav col-1-1">
<ul class="nested-cols categories-nav_categories">
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/elections" class="categories-nav_link categories-nav_title">
Kenya Elections
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/elections/presidential" class="categories-nav_link ">Presidential</a>
</li>
<li>
<a href="/kenya/elections/governor-race" class="categories-nav_link ">Governor Race</a>
</li>
<li>
<a href="/kenya/elections/county-profiles" class="categories-nav_link ">County Profiles</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/news" class="categories-nav_link categories-nav_title">
News
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/news/national" class="categories-nav_link ">National</a>
</li>
<li>
<a href="/kenya/news/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/news/world" class="categories-nav_link ">World</a>
</li>
<li>
<a href="/kenya/news/gender" class="categories-nav_link ">Gender</a>
</li>
<li>
<a href="/kenya/news/tech" class="categories-nav_link ">Tech</a>
</li>
<li>
<a href="/kenya/news/newsplex" class="categories-nav_link ">Newsplex</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category current-section">
<a href="/kenya/counties" class="categories-nav_link categories-nav_title">
Counties
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/counties/nairobi-metro" class="categories-nav_link current-section">Nairobi Metro</a>
</li>
<li>
<a href="/kenya/counties/coast" class="categories-nav_link current-section">Coast</a>
</li>
<li>
<a href="/kenya/counties/mountain" class="categories-nav_link current-section">Mountain</a>
</li>
<li>
<a href="/kenya/counties/lake-region" class="categories-nav_link current-section">Lake Region</a>
</li>
<li>
<a href="/kenya/counties/rift-valley" class="categories-nav_link current-section">Rift Valley</a>
</li>
<li>
<a href="/kenya/counties/northern" class="categories-nav_link current-section">Northern</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/business" class="categories-nav_link categories-nav_title">
Business
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/business/companies" class="categories-nav_link ">Companies</a>
</li>
<li>
<a href="/kenya/business/finance-and-markets" class="categories-nav_link ">Finance and Markets</a>
</li>
<li>
<a href="/kenya/business/seeds-of-gold" class="categories-nav_link ">Seeds of Gold</a>
</li>
<li>
<a href="/kenya/business/enterprise" class="categories-nav_link ">Enterprise</a>
</li>
<li>
<a href="/kenya/business/shillings-sense" class="categories-nav_link ">Shillings &amp; Sense</a>
</li>
<li>
<a href="/kenya/business/leadership" class="categories-nav_link ">Leadership</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/blogs-opinion" class="categories-nav_link categories-nav_title">
Opinion
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/blogs-opinion/editorials" class="categories-nav_link ">Editorials</a>
</li>
<li>
<a href="/kenya/blogs-opinion/opinion" class="categories-nav_link ">Our Columnists</a>
</li>
<li>
<a href="/kenya/blogs-opinion/blogs" class="categories-nav_link ">Guest Blogs</a>
</li>
<li>
<a href="/kenya/blogs-opinion/letters" class="categories-nav_link ">Letters to the Editor</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cutting-edge" class="categories-nav_link ">Cutting Edge</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cartoons" class="categories-nav_link ">Cartoons</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/sports" class="categories-nav_link categories-nav_title">
Sports
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/sports/football" class="categories-nav_link ">Football</a>
</li>
<li>
<a href="/kenya/sports/athletics" class="categories-nav_link ">Athletics</a>
</li>
<li>
<a href="/kenya/sports/rugby" class="categories-nav_link ">Rugby</a>
</li>
<li>
<a href="/kenya/sports/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/sports/talkup" class="categories-nav_link ">TalkUP!</a>
</li>
<li>
<a href="/kenya/sports/other-sports" class="categories-nav_link ">Other Sports</a>
</li>
<li>
<a href="/kenya/sports/motorsports" class="categories-nav_link ">Motorsport</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/life-and-style" class="categories-nav_link categories-nav_title">
Life &amp; Style
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/life-and-style/culture" class="categories-nav_link ">Culture</a>
</li>
<li>
<a href="/kenya/life-and-style/family" class="categories-nav_link ">Family</a>
</li>
<li>
<a href="/kenya/life-and-style/relationships" class="categories-nav_link ">Relationships</a>
</li>
<li>
<a href="/kenya/life-and-style/art-books" class="categories-nav_link ">Art &amp; Books</a>
</li>
<li>
<a href="/kenya/life-and-style/travel" class="categories-nav_link ">Travel</a>
</li>
<li>
<a href="/kenya/life-and-style/wellness" class="categories-nav_link ">Wellness</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/health" class="categories-nav_link categories-nav_title">
Health
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/health/women-s-health" class="categories-nav_link ">Women&#39;s Health</a>
</li>
<li>
<a href="/kenya/health/men-s-health" class="categories-nav_link ">Men&#39;s Health</a>
</li>
<li>
<a href="/kenya/health/healthy-nation" class="categories-nav_link ">Healthy Nation</a>
</li>
<li>
<a href="/kenya/health/tips" class="categories-nav_link ">Tips</a>
</li>
<li>
<a href="/kenya/health/expert-corner" class="categories-nav_link ">Expert Corner</a>
</li>
<li>
<a href="/kenya/health/talking-point" class="categories-nav_link ">Talking Point</a>
</li>
<li>
<a href="/kenya/health/covid-19" class="categories-nav_link ">Covid-19</a>
</li>
<li>
<a href="/kenya/health/emergency-contacts" class="categories-nav_link ">Emergency Contacts</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/audio" class="categories-nav_link categories-nav_title">
Audio
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/puzzles" class="categories-nav_link categories-nav_title">
Puzzles
</a>
</li>
</ul>
</nav> </div>
<nav class="channels-nav">
<ul class="grid-container">
<li class="col-1-1 medium-col-1-3">
<h2 class="channels-nav_heading">Editions</h2>
<ul>
<li class="channels-nav_link-item">
<a href="https://nation.africa/africa" rel="noopener">Africa</a>
</li>
<li class="channels-nav_link-item active-edition">
<a href="/kenya" rel="noopener">Kenya</a>
</li>
<li class="channels-nav_link-item">
<a href="https://www.monitor.co.ug/uganda" rel="noopener">Uganda</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3">
<hr>
<h2 class="channels-nav_heading">ePaper</h2>
<ul>
<li class="channels-nav_link-item">
<a href="https://epaper.nation.africa/ke" target="_blank" rel="noopener">Daily Nation</a>
</li>
<li class="channels-nav_link-item">
<a href="https://epaper.nation.africa/ug" target="_blank" rel="noopener">Daily Monitor</a>
</li>
</ul>
</li>
</ul>
</nav> </section>
</nav>
<div class="breaking-news">
<div class="container">
<div class="breaking-news-container" data-separator="" data-fragments-link="/ajax/breaking-news/kenya">
</div>
</div>
</div></header> </header>
<div class="article-page" data-article-content>
<header class="article-header">
<div class="grid-container-small">
<div class="col-1-1">
<div class="ad-mobile-leaderboard_wrap">
<div id="mobile-article-ad-top" class="ad-mobile-leaderboard">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-top");
});
}
</script>
</div>
</div>
<div class="ad-leaderboard_wrap">
<div id="desktop-article-above-navigation" class="ad-leaderboard">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-above-navigation");
});
}
</script>
</div>
</div>
<h1 class="title-medium">Man kills wife and jumps into a well in Nakuru </h1>
<time class="date" datetime="2022-09-10T17:16:42Z">
Saturday, September 10, 2022
</time>
<figure class="article-picture">
<div class="lazy-img-container img-space_landscape_ratio2x1">
<img src="/resource/image/3944334/landscape_ratio2x1/320/160/75b264a34ea77248a709436fc0c4845b/SW/new-content-item.gif" srcset="
/resource/image/3944334/landscape_ratio2x1/320/160/75b264a34ea77248a709436fc0c4845b/SW/new-content-item.gif 320w,
/resource/image/3944334/landscape_ratio2x1/640/320/75b264a34ea77248a709436fc0c4845b/PF/new-content-item.gif 640w,
/resource/image/3944334/landscape_ratio2x1/720/360/75b264a34ea77248a709436fc0c4845b/sU/new-content-item.gif 720w,
/resource/image/3944334/landscape_ratio2x1/960/480/75b264a34ea77248a709436fc0c4845b/Px/new-content-item.gif 960w,
/resource/image/3944334/landscape_ratio2x1/1280/640/75b264a34ea77248a709436fc0c4845b/MX/new-content-item.gif 1280w
" sizes="(min-width: 820px) 820px, (min-width: 630px) 630px, 100vw" width="100" height="100" alt="Kuresoi murder " />
</div>
<figcaption class="article-picture_caption">
<p>A  man who allegedly killed his wife before jumping into a well at Mawingu Village in Kuresoi North, Nakuru County is frogmarched into a waiting police vehicle on September 10, 2022.</p>
<div class="article-picture_copyright"><span class="article-picture_credit">Photo credit:</span> John Njoroge | Nation Media Group</div>
</figcaption>
</figure>
</div>
</div>
</header>
<div class="article-content xxx">
<div class="grid-container-small">
<div class="col-1-1">
<div class="article-authors">
<div class="article-authors_inner clearfix">
<div class="article-authors_imgs clearfix">
<figure class="article-authors_img lazy-img-container" style="z-index: 1;">
<a href="/kenya/john-njoroge-6378">
<img data-src="/resource/image/6380/portrait_ratio1x1/60/60/606c98fdb04f7fb53ab05d8595f8b854/uP/john-njoroge.jpg" data-srcset="
/resource/image/6380/portrait_ratio1x1/60/60/606c98fdb04f7fb53ab05d8595f8b854/uP/john-njoroge.jpg 60w,
/resource/image/6380/portrait_ratio1x1/120/120/606c98fdb04f7fb53ab05d8595f8b854/Ks/john-njoroge.jpg 120w
" sizes="60px" alt="" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</a>
</figure>
</div>
<div class="article-authors_texts">
<p class="article-authors_authors clearfix">
<span>By&nbsp;</span>
<a href="/kenya/john-njoroge-6378">John Njoroge</a>
</p>
<p class="article-authors_org">Nation Media Group</p>
</div>
</div>
</div>
<div class="articles-left-notifier" data-articles-left-notifier hidden>
<aside class="promotion-banner color-set-color-5">
<div class="promotion-banner_texts">
<h2>Thank you for reading Nation.Africa</h2>
<p data-articles-left-message></p>
<a href="/kenya/subscribe" class="default-btn">
Show plans
</a>
</div>
</aside>
</div>
<section>
<div class="text-block">
<div class="paragraph-wrapper">
<p>A 26-year-old man killed his wife before unsuccessfully trying to jump into a 60-metre deep well at Mawingu village in Kuresoi North, Nakuru County on Saturday.</p> </div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-1" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-1");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
if(!document.hidden) {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-1']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}
}, 60000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-1" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-1");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
if(!document.hidden) {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-1']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}
}, 60000);
}
</script>
</div>
</div>
<div class="paragraph-wrapper">
<p>The suspect slit the throat of his 20-year-old wife as their two-year-old daughter watched.   </p> </div>
<div class="paragraph-wrapper">
<p>Kuresoi North Police Commander James Ademba said: "The suspect killed his wife inside their sitting room, we have launched investigations to establish the motive behind the murder.</p> </div>
<section class="teasers-row related-in-content">
<div class="grid-container">
<div class="col-1-1 medium-col-1-1 large-col-1-1">
<div class="col-1-1">
<header class="teasers-row_header">
<h2 class="section-label" style="background: #FF415D; color:#000000;">
Also Read
</h2>
</header>
</div>
<ul class="article-collection">
<li class="col-1-1 medium-col-1-2 large-col-1-2">
<a href="/kenya/counties/kisumu/-floods-displace-100-families-as-river-nyando-breaks-its-banks--3944220" aria-label=" Floods displace 100 families as River Nyando breaks its banks " class="teaser-image-right article-collection-teaser related-in-content ">
<article class="nested-cols">
<div class="teaser-image-right_summary col-3-4">
<h3 class="teaser-image-right_title title-extra-small">
Floods displace 100 families as River Nyando breaks its banks
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Kisumu</span>
<span class="date">
4 hours ago
</span>
</aside>
</div>
<div class="col-1-4">
<figure class="lazy-img-container img-space_portrait_ratio1x1">
<img src="/resource/image/3944226/portrait_ratio1x1/70/70/f2f560e6986990ba9f1e80a819f241d7/zE/floods1.jpg" srcset="
/resource/image/3944226/portrait_ratio1x1/70/70/f2f560e6986990ba9f1e80a819f241d7/zE/floods1.jpg 70w,
/resource/image/3944226/portrait_ratio1x1/140/140/f2f560e6986990ba9f1e80a819f241d7/Pi/floods1.jpg 140w,
/resource/image/3944226/portrait_ratio1x1/210/210/f2f560e6986990ba9f1e80a819f241d7/aU/floods1.jpg 210w,
/resource/image/3944226/portrait_ratio1x1/420/420/f2f560e6986990ba9f1e80a819f241d7/FL/floods1.jpg 420w,
/resource/image/3944226/portrait_ratio1x1/630/630/f2f560e6986990ba9f1e80a819f241d7/Wq/floods1.jpg 630w
" sizes="(min-width: 1240px) 315px, 20vw" width="100" height="100" alt="Ombaka Village floods" />
</figure>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-2">
<a href="/kenya/counties/kisii/governor-arati-launches-new-programs-to-assist-needy-kisii-families-3944186" aria-label="Governor Arati launches new programs to assist needy families" class="teaser-image-right article-collection-teaser related-in-content ">
<article class="nested-cols">
<div class="teaser-image-right_summary col-3-4">
<h3 class="teaser-image-right_title title-extra-small">
Governor Arati launches new programs to assist needy families
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Kisii</span>
<span class="date">
5 hours ago
</span>
</aside>
</div>
<div class="col-1-4">
<figure class="lazy-img-container img-space_portrait_ratio1x1">
<img src="/resource/image/3944204/portrait_ratio1x1/70/70/9a6316c8fcbf4958578edb9a0564ff8b/lS/jane-pix.jpg" srcset="
/resource/image/3944204/portrait_ratio1x1/70/70/9a6316c8fcbf4958578edb9a0564ff8b/lS/jane-pix.jpg 70w,
/resource/image/3944204/portrait_ratio1x1/140/140/9a6316c8fcbf4958578edb9a0564ff8b/no/jane-pix.jpg 140w,
/resource/image/3944204/portrait_ratio1x1/210/210/9a6316c8fcbf4958578edb9a0564ff8b/Zu/jane-pix.jpg 210w,
/resource/image/3944204/portrait_ratio1x1/420/420/9a6316c8fcbf4958578edb9a0564ff8b/Al/jane-pix.jpg 420w,
/resource/image/3944204/portrait_ratio1x1/630/630/9a6316c8fcbf4958578edb9a0564ff8b/DM/jane-pix.jpg 630w
" sizes="(min-width: 1240px) 315px, 20vw" width="100" height="100" alt="Jane Ndemo is handed a cheque by officials from Simba Education Fund." />
</figure>
</div>
</article>
</a> </li>
</ul>
</div>
</div>
</section>
<div class="paragraph-wrapper">
<p>Read: <a href="https://nation.africa/kenya/counties/laikipia/-laikipia-man-accuses-wife-of-infidelity-kills-son-and-hangs-himself--3928434" target="_blank" rel="noopener"><strong><em>Laikipia man accuses wife of infidelity, kills son and hangs himself </em></strong></a></p> </div>
<div class="paragraph-wrapper">
<p>"The suspect will be arraigned in court once investigations are complete.</p> </div>
<div class="paragraph-wrapper">
<p>Police officers had a difficult time controlling onlookers who were baying for the suspect's blood after he was removed from the well.   </p> </div>
<div class="paragraph-wrapper">
<p>Mr Julius Ndirangu said the victim was a polite and humble woman while her husband worked as a casual worker in the area.</p> </div>
<div class="paragraph-wrapper">
<p>"Abuse of drugs and consumption of illicit brew could have made the suspect brutally kill his wife," said Mr Ndirangu.</p> </div>
<div class="paragraph-wrapper">
<p>His words were echoed by Stephen Sang who said many youths in the area have engaged themselves in alcoholism.</p> </div>
<div class="paragraph-wrapper">
<p>Neighbours said after the incident, the suspect rushed to his mother and urged her to pick up the child from the murder scene.</p> </div>
<div class="paragraph-wrapper">
<p>Ms Caroline Chebet, a resident, said neighbours rushed to the scene where they found the body of the victim in a pool of blood.</p> </div>
<div class="paragraph-wrapper">
<p>Read: <a href="https://nation.africa/kenya/counties/homa-bay/woman-kills-husband-in-homa-bay-over-mobile-phone-text-messages-3879218" target="_blank" rel="noopener"><strong><em>Woman kills husband in Homa Bay over mobile phone text messages</em></strong></a></p> </div>
<div class="paragraph-wrapper">
<p>"The victim, who was my close friend, came the previous evening and informed me that she was going through a hard time with her husband. She urged me to go and tell her mother about her troubled marriage," said Ms Chebet.</p> </div>
<div class="paragraph-wrapper">
<p>The victim's mother, who lived nearby, said the victim was her firstborn child. She had three children.</p> </div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-2" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-2");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
if(!document.hidden) {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-2']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}
}, 60000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-2" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-2");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
if(!document.hidden) {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-2']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}
}, 60000);
}
</script>
</div>
</div>
<div class="paragraph-wrapper">
<p>The body of the victim was moved to Molo Sub County Hospital mortuary while the suspect is being detained at Kuresoi police station.</p> </div>
<div class="paragraph-wrapper">
<p><em><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="17797d78657870727d62797e786557707a767e7b3974787a">[email&#160;protected]</a></em></p> </div>
</div>
</section>
<aside class="promotion-banner color-set-color-5">
<div class="promotion-banner_texts">
<h2>Nation. Empower Africa.</h2>
<p>
<strong>We come to you.</strong>
We are always looking for ways to improve our stories. Let us know what you liked and what we can improve on.
</p>
<a href="https://docs.google.com/forms/d/e/1FAIpQLSfOOJA0WUAChH42ijf4Xj1kVFuxGzwLEWYMpfHmzxqiWTh_ow/viewform?usp=pp_url&amp;entry.582792058=Man%20kills%20wife%20and%20jumps%20into%20a%20well%20in%20Nakuru%20" class="default-btn" target="_blank" rel="nofollow noopener">I&#39;ve got feedback!</a>
</div>
</aside>
<aside>
<ul class="social-share-list">
<li>
<div class="fb-share-button">
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344" rel="noopener noreferrer" aria-label="Share on Facebook">
<svg class="icon-social-facebook" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-facebook"></use>
</svg>
</a>
</div>
</li>
<li>
<a target="_blank" class="twitter-share-button" href="https://twitter.com/intent/tweet?text=Man%20kills%20wife%20and%20jumps%20into%20a%20well%20in%20Nakuru%20&url=https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344" " rel="noopener noreferrer" aria-label="Share on Twitter">
<svg class="icon-social-twitter" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-twitter"></use>
</svg>
</a>
</li>
<li>
<a target="_blank" class="whatsapp-share-button" href="https://wa.me/?text=https://nation.africa/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344" rel="noopener noreferrer" aria-label="Share on Whatsapp">
<svg class="icon-social-whatsapp" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-whatsapp"></use>
</svg>
</a>
</li>
<li>
<a target="_blank" class="email-share-button" href="/cdn-cgi/l/email-protection#506f2325323a3533246d1d313e703b393c3c23702739363570313e34703a253d202370393e243f70317027353c3c70393e701e313b2522257076323f34296d38242420236a7f7f3e3124393f3e7e3136223933317f3b353e29317f333f253e243935237f3e313b2522257f3d313e7d3b393c3c237d273936357d313e347d3a253d20237d393e243f7d317d27353c3c7d393e7d3e313b2522257d7d63696464636464" rel="noopener noreferrer" aria-label="Share via email">
<svg class="icon-social-email" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-email"></use>
</svg>
</a>
</li>
<li>
<ev-share-article-btn widget-count="3" share-article-group="articleShare" share-button-text="Premium share" data-article-share-toggle>
</ev-share-article-btn>
</li>
</ul>
</aside>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-3" class="content-page-ad content-page-ad_desktop">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-3");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
if(!document.hidden) {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-3']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}
}, 60000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-3" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-3");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
if(!document.hidden) {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-3']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}
}, 60000);
}
</script>
</div>
</div>
</div>
</div>
</div>
<section class="teasers-row">
<header class="teasers-row_header grid-container">
<div class="col-1-1 clearfix">
<h2 class="section-label" style="background: #FFB600; color:#000000;">
<a href="/kenya">In the headlines</a>
</h2>
<nav class="subcategories-list">
<ul>
<li>
<a href="/kenya/elections" class="link-more ">
Kenya Elections
</a>
</li>
<li>
<a href="/kenya/news" class="link-more ">
News
</a>
</li>
<li>
<a href="/kenya/counties" class="link-more ">
Counties
</a>
</li>
<li>
<a href="/kenya/business" class="link-more ">
Business
</a>
</li>
<li>
<a href="/kenya/blogs-opinion" class="link-more ">
Opinion
</a>
</li>
<li>
<a href="/kenya/sports" class="link-more ">
Sports
</a>
</li>
<li>
<a href="/kenya/life-and-style" class="link-more ">
Life &amp; Style
</a>
</li>
<li>
<a href="/kenya/health" class="link-more ">
Health
</a>
</li>
<li>
<a href="/kenya/audio" class="link-more ">
Audio
</a>
</li>
<li>
<a href="/kenya/puzzles" class="link-more ">
Puzzles
</a>
</li>
</ul>
</nav>
</div>
</header>
<div class="teasers-row_nested-row teasers-row_nested-row-3-col">
<ul class="grid-container">
<li class="col-1-1 large-col-1-3">
<a href="/kenya/news/politics/azimio-defectors-meet-william-ruto-pledge-support-3943624" aria-label="Azimio defectors meet William Ruto, pledge support" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
medium-col-1-2 large-col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3943626/landscape_ratio3x2/300/200/27729c5b53055213069bc9e0d81b47f3/xK/gema-pix.jpg" data-srcset="
/resource/image/3943626/landscape_ratio3x2/300/200/27729c5b53055213069bc9e0d81b47f3/xK/gema-pix.jpg 300w,
/resource/image/3943626/landscape_ratio3x2/600/400/27729c5b53055213069bc9e0d81b47f3/ub/gema-pix.jpg 600w,
/resource/image/3943626/landscape_ratio3x2/900/600/27729c5b53055213069bc9e0d81b47f3/UY/gema-pix.jpg 900w,
/resource/image/3943626/landscape_ratio3x2/1200/800/27729c5b53055213069bc9e0d81b47f3/vI/gema-pix.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Gema Cultural Association executive council members." width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
medium-col-1-2 large-col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Azimio defectors meet William Ruto, pledge support
</h3>
<p class="teaser-image-large_paragraph text-block">
Post-election Kisii leaders have formed Taifa Democratic Coalition to work with Ruto</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Politics</span>
<span class="date">
17 hours ago
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-3">
<a href="/kenya/news/politics/ruto-team-goes-after-four-iebc-dissenters-3943620" aria-label="Ruto allies go for IEBC four" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3943622/landscape_ratio3x2/300/200/4da7f9801add1320ffb1da0d884c0cc1/DD/pic-cherera-2.jpg" data-srcset="
/resource/image/3943622/landscape_ratio3x2/300/200/4da7f9801add1320ffb1da0d884c0cc1/DD/pic-cherera-2.jpg 300w,
/resource/image/3943622/landscape_ratio3x2/600/400/4da7f9801add1320ffb1da0d884c0cc1/UE/pic-cherera-2.jpg 600w,
/resource/image/3943622/landscape_ratio3x2/900/600/4da7f9801add1320ffb1da0d884c0cc1/oJ/pic-cherera-2.jpg 900w,
/resource/image/3943622/landscape_ratio3x2/1200/800/4da7f9801add1320ffb1da0d884c0cc1/vp/pic-cherera-2.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="IEBC commissioners from left: Justus Nyang&#39;aya, Francis Wanderi, Vice-chairperson Juliana Cherera and Irene Masit." width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Ruto allies go for IEBC four
</h3>
<p class="teaser-image-large_paragraph text-block">
Petition already filed with the National Assembly, with another from Duale in the offing</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Politics</span>
<span class="date">
12 hours ago
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-3">
<a href="/kenya/news/kenya-s-lengthy-dalliance-with-queen-elizabeth-ii-3943488" aria-label="Kenya’s lengthy dalliance with Queen Elizabeth II" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3943526/landscape_ratio3x2/300/200/5e732b544f18d1507c51f97a05d9403f/dA/queen1-pix.jpg" data-srcset="
/resource/image/3943526/landscape_ratio3x2/300/200/5e732b544f18d1507c51f97a05d9403f/dA/queen1-pix.jpg 300w,
/resource/image/3943526/landscape_ratio3x2/600/400/5e732b544f18d1507c51f97a05d9403f/Gh/queen1-pix.jpg 600w,
/resource/image/3943526/landscape_ratio3x2/900/600/5e732b544f18d1507c51f97a05d9403f/Dy/queen1-pix.jpg 900w,
/resource/image/3943526/landscape_ratio3x2/1200/800/5e732b544f18d1507c51f97a05d9403f/BW/queen1-pix.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Queen Elizabeth with Jomo Kenyatta at State House, Nairobi." width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Kenya’s lengthy dalliance with Queen Elizabeth II
</h3>
<p class="teaser-image-large_paragraph text-block">
The Queen ascended to the throne in 1952 on the steps of State House Nairobi, then known as Government House.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">News</span>
<span class="date">
17 hours ago
</span>
</aside>
</div>
</article>
</a> </li>
</ul>
<div class="grid-container border-wrapper">
<div class="col-1-1">
<hr />
</div>
</div>
</div> </section>
<div id="taboola-below-article-thumbnails1"></div>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({
mode: 'alternating-thumbnails-a',
container: 'taboola-below-article-thumbnails1',
placement: 'Below Article Thumbnails1',
target_type: 'mix'
});
</script>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1714",
postid: "new-3944344",
maincontent: ".article-content",
title: "Man kills wife and jumps into a well in Nakuru ",
pubdate: "2022-09-10 08:16:42",
authors: "John Njoroge",
sections: "Nakuru",
tags: "Investigations, murder, Kuresoi,James Ademba ,Mawingu village in Kuresoi North,Man kills wife",
comments: ""
};
/* CONFIGURATION END */
let parts = location.pathname.split('/');
parts.splice(0,1);
parts.splice(parts.length-1);
_ain.sections = parts.join('>');
/* CONFIGURATION END */
(function(d, s) {
const sf = d.createElement(s);
sf.type = 'text/javascript';
sf.async = !0;
sf.src = (('https:' == d.location.protocol) ? 'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com' : 'http://t.contentinsights.com') + '/stf.js';
const t = d.getElementsByTagName(s)[0];
t.parentNode.insertBefore(sf, t)
})(document, 'script')
</script></div>
<aside class="error-message-block" style="display: none;" role="alert" data-article-error>
<h1 class="title-small">Oops</h1>
<h2 class="title-normal">
We're sorry, we couldn't load the article
</h2>
<p>
If you have an Ad-blocker please disable it and reload the page or try again later.
</p>
<button type="button" class="default-btn" onclick="window.location.reload()">Reload page</button>
</aside>
<footer class="page-footer color-set-color-8" data="page-footer">
<div class="page-footer_top grid-container">
<nav role="navigation" aria-label="Site index" class="categories-nav col-1-1">
<ul class="nested-cols categories-nav_categories">
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/elections" class="categories-nav_link categories-nav_title">
Kenya Elections
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/elections/presidential" class="categories-nav_link ">Presidential</a>
</li>
<li>
<a href="/kenya/elections/governor-race" class="categories-nav_link ">Governor Race</a>
</li>
<li>
<a href="/kenya/elections/county-profiles" class="categories-nav_link ">County Profiles</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/news" class="categories-nav_link categories-nav_title">
News
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/news/national" class="categories-nav_link ">National</a>
</li>
<li>
<a href="/kenya/news/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/news/world" class="categories-nav_link ">World</a>
</li>
<li>
<a href="/kenya/news/gender" class="categories-nav_link ">Gender</a>
</li>
<li>
<a href="/kenya/news/tech" class="categories-nav_link ">Tech</a>
</li>
<li>
<a href="/kenya/news/newsplex" class="categories-nav_link ">Newsplex</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/counties" class="categories-nav_link categories-nav_title">
Counties
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/counties/nairobi-metro" class="categories-nav_link ">Nairobi Metro</a>
</li>
<li>
<a href="/kenya/counties/coast" class="categories-nav_link ">Coast</a>
</li>
<li>
<a href="/kenya/counties/mountain" class="categories-nav_link ">Mountain</a>
</li>
<li>
<a href="/kenya/counties/lake-region" class="categories-nav_link ">Lake Region</a>
</li>
<li>
<a href="/kenya/counties/rift-valley" class="categories-nav_link ">Rift Valley</a>
</li>
<li>
<a href="/kenya/counties/northern" class="categories-nav_link ">Northern</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/business" class="categories-nav_link categories-nav_title">
Business
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/business/companies" class="categories-nav_link ">Companies</a>
</li>
<li>
<a href="/kenya/business/finance-and-markets" class="categories-nav_link ">Finance and Markets</a>
</li>
<li>
<a href="/kenya/business/seeds-of-gold" class="categories-nav_link ">Seeds of Gold</a>
</li>
<li>
<a href="/kenya/business/enterprise" class="categories-nav_link ">Enterprise</a>
</li>
<li>
<a href="/kenya/business/shillings-sense" class="categories-nav_link ">Shillings &amp; Sense</a>
</li>
<li>
<a href="/kenya/business/leadership" class="categories-nav_link ">Leadership</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/blogs-opinion" class="categories-nav_link categories-nav_title">
Opinion
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/blogs-opinion/editorials" class="categories-nav_link ">Editorials</a>
</li>
<li>
<a href="/kenya/blogs-opinion/opinion" class="categories-nav_link ">Our Columnists</a>
</li>
<li>
<a href="/kenya/blogs-opinion/blogs" class="categories-nav_link ">Guest Blogs</a>
</li>
<li>
<a href="/kenya/blogs-opinion/letters" class="categories-nav_link ">Letters to the Editor</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cutting-edge" class="categories-nav_link ">Cutting Edge</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cartoons" class="categories-nav_link ">Cartoons</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/sports" class="categories-nav_link categories-nav_title">
Sports
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/sports/football" class="categories-nav_link ">Football</a>
</li>
<li>
<a href="/kenya/sports/athletics" class="categories-nav_link ">Athletics</a>
</li>
<li>
<a href="/kenya/sports/rugby" class="categories-nav_link ">Rugby</a>
</li>
<li>
<a href="/kenya/sports/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/sports/talkup" class="categories-nav_link ">TalkUP!</a>
</li>
<li>
<a href="/kenya/sports/other-sports" class="categories-nav_link ">Other Sports</a>
</li>
<li>
<a href="/kenya/sports/motorsports" class="categories-nav_link ">Motorsport</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/life-and-style" class="categories-nav_link categories-nav_title">
Life &amp; Style
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/life-and-style/culture" class="categories-nav_link ">Culture</a>
</li>
<li>
<a href="/kenya/life-and-style/family" class="categories-nav_link ">Family</a>
</li>
<li>
<a href="/kenya/life-and-style/relationships" class="categories-nav_link ">Relationships</a>
</li>
<li>
<a href="/kenya/life-and-style/art-books" class="categories-nav_link ">Art &amp; Books</a>
</li>
<li>
<a href="/kenya/life-and-style/travel" class="categories-nav_link ">Travel</a>
</li>
<li>
<a href="/kenya/life-and-style/wellness" class="categories-nav_link ">Wellness</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/health" class="categories-nav_link categories-nav_title">
Health
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/health/women-s-health" class="categories-nav_link ">Women&#39;s Health</a>
</li>
<li>
<a href="/kenya/health/men-s-health" class="categories-nav_link ">Men&#39;s Health</a>
</li>
<li>
<a href="/kenya/health/healthy-nation" class="categories-nav_link ">Healthy Nation</a>
</li>
<li>
<a href="/kenya/health/tips" class="categories-nav_link ">Tips</a>
</li>
<li>
<a href="/kenya/health/expert-corner" class="categories-nav_link ">Expert Corner</a>
</li>
<li>
<a href="/kenya/health/talking-point" class="categories-nav_link ">Talking Point</a>
</li>
<li>
<a href="/kenya/health/covid-19" class="categories-nav_link ">Covid-19</a>
</li>
<li>
<a href="/kenya/health/emergency-contacts" class="categories-nav_link ">Emergency Contacts</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/audio" class="categories-nav_link categories-nav_title">
Audio
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/puzzles" class="categories-nav_link categories-nav_title">
Puzzles
</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-label="Site Information Navigation" class="page-footer_metanav col-1-2 medium-col-2-3">
<ul class="clearfix">
<li><a href="/kenya/empower" target="_blank">Empower Africa</a></li>
<li><a href="/kenya/contact-us-294088" target="_blank">Contact Us</a></li>
<li><a href="/kenya/frequently-asked-questions-303716" target="_blank">Frequently asked questions</a></li>
<li><a href="/kenya/nmg-privacy-policy-303724" target="_blank">NMG Privacy Policy</a></li>
<li><a href="/kenya/terms-and-conditions" target="_blank">Terms and Conditions of Use</a></li>
<li><a href="/kenya/our-blog-rules-549010" target="_blank">Our Blog Rules</a></li>
</ul>
</nav>
<p class="page-footer_copyright col-1-1 medium-col-1-3">
<span class="page-footer_copyright-year">Nation Media Group &copy; 2022</span>
</p>
</div>
<figure class="page-footer_decoration">
<img data-src="/resource/crblob/1337610/4ffe0a0e8c1ddb5abcac8c8d4862e60e/footer-decoration-svg-data.svg" alt="Decoration" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</footer></section>
<div class="evolok-widgets">
<ev-paywall group-name="default" redirect=false></ev-paywall>
<ev-paywall-notifier></ev-paywall-notifier>
<div style="visibility: hidden; height: 0px; overflow: hidden; position: absolute;">
<div id="registration-welcome" ev-modal>
<div class="registration-welcome">
<div class="ev-widget-header">
<p>Welcome!</p>
</div>
<div class="ev-widget-body">
<div class="ev-text-wrapper">
<div class="ev-title-wrapper">
<h3>You're all set to enjoy unlimited Prime content.</h3>
</div>
</div>
<div class="ev-button-wrapper">
<div>
<button class="btn">
Start reading
</button>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<script>
var evolokParams = {
articleId: '3944344',
section: 'Counties',
category: 'Nakuru',
authors: 'John Njoroge',
site: 'Nation',
tags: 'Investigations',
contentType: 'article',
publishDate: '2022-09-10T17:16:42Z',
premium: false
};
var evolokInitParams = {
url: 'https://ev.nation.africa',
enableSSOMode: false,
enableSeamlessMode: false,
cookieDomain: 'nation.africa',
socialLoginRedirectUri: 'https://nation.africa/kenya/account',
homepageUrl: '/kenya',
termsAndConditionsUrl: '/kenya/terms-and-conditions',
faqUrl: '/kenya/frequently-asked-questions-303716',
signUpUrl: '/kenya/account/signup',
signInUrl: '/kenya/account/signin'
}
</script>
<script>
window.polyfillsForOldBrowsersLoaded = false;
if ("Promise" in window &&
!!window.HTMLPictureElement &&
'objectFit' in document.documentElement.style) {
window.polyfillsForOldBrowsersLoaded = true;
} else {
var f = document.getElementsByTagName('script')[0];
var j = document.createElement('script');
j.async = true;
j.src = "/resource/themes/nation-2020/js/polyfills-for-old-browsers.ts-491110-59.js";
f.parentNode.insertBefore(j,f);
}
</script>
<script data-evolok-script="true" async data-src="https://scripts.nation.africa/ev-widgets.min-v3.22.0.js"></script>
<script data-metering-script="true" async data-src="https://scripts.nation.africa/ev-em.min-v3.4.4.js"></script>
<link rel="stylesheet" href="https://scripts.nation.africa/css/ev-widgets.min-v3.22.0.css">
<link rel="stylesheet" href="https://scripts.nation.africa/css/ev-em.min-v3.4.4.css">
<script async src="/resource/themes/nation-2020/js/nation-2020.ts-491108-184.js"></script>
<script id="doubleClickJS" async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<!--[if IE 9]> <script>
var dcScript = document.getElementById("doubleClickJS");
dcScript.parentNode.removeChild(dcScript);
</script> <![endif]-->
<script type='text/javascript'>
var isVideoPage = false;
var trackVideo = isVideoPage || window.hasEmbeddedVideo === true;
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'nation.africa';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'Counties,Counties - Nakuru';
_sf_async_config.authors ='John Njoroge';
/** Handle user subscriber tracking */
// var _cbq = window._cbq = (window._cbq || []);
// setTimeout(() => {
// var servicesWrapper = document.querySelector('[data=profile-services]');
// if (servicesWrapper) {
// var services = servicesWrapper.textContent;
// if (services.includes('subscription')) {
// _cbq.push(['_acct', 'paid']);
// }
// else if (!services.includes('subscription') && services.includes('registration')) {
// _cbq.push(['_acct', 'lgdin']);
// } else {
// _cbq.push(['_acct', 'anon']);
// }
// }
// }, 1000);
/** CONFIGURATION END **/
function loadChartbeat() {
var chartbeatScript = document.createElement('script');
chartbeatScript.type = 'text/javascript';
chartbeatScript.async = true;
chartbeatScript.src = '//static.chartbeat.com/js/chartbeat.js';
var n = document.getElementsByTagName('script')[0];
n.parentNode.insertBefore(chartbeatScript, n);
}
function loadChartbeatWithVideoTracking() {
// YouTube's API script, required for Chartbeat's video engagement tracking -->
var youtubeScript = document.createElement('script');
youtubeScript.type = 'text/javascript';
youtubeScript.async = true;
youtubeScript.src = '//www.youtube.com/iframe_api';
// Chartbeat Video script
var chartbeatVideoScript = document.createElement('script');
chartbeatVideoScript.type = 'text/javascript';
chartbeatVideoScript.async = true;
chartbeatVideoScript.src = '//static.chartbeat.com/js/chartbeat_video.js';
// Include both scripts
var n = document.getElementsByTagName('script')[0];
n.parentNode.insertBefore(youtubeScript, n);
n.parentNode.insertBefore(chartbeatVideoScript, n);
}
if (trackVideo) {
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeatWithVideoTracking();
} else {
loadChartbeat();
}
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript">
function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(disableAdFeaturesPlugin, contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function setupGa(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
}
function setGaCustomDimension(name, content, trackerName) {
var t = _gaTrackerPrefix(trackerName);
ga(t.concat('set'), name, content);
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-1030601-83", "nation.africa");
var gaPageData = new GaPageviewData(
false,
"3944344",
"CMArticle",
"31772_522_1134",
"/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344"
,"John Njoroge",
"10-09-2022 20:16",
"Investigations"
);
setupGa(ga, gaAccountData, gaPageData);
function sendGaTrackPageview() {
gaTrackPageview(ga, gaAccountData, gaPageData);
}
</script>
<script>
window.dataLayer = window.dataLayer || [];
window.dataLayer.push({
'contentId': '3944344',
'contentType': 'CMArticle',
'navigationPath': '31772_522_1134',
'userSegments': '/kenya/counties/nakuru/man-kills-wife-and-jumps-into-a-well-in-nakuru--3944344',
'authors': 'John Njoroge',
'pubDate': '10-09-2022 20:16',
'tags': 'Investigations'
});
</script>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script>
<script>
window.googletag = window.googletag || {cmd: []};
googletag.cmd.push(function() {
googletag.defineOutOfPageSlot('/1010816/NA_1x1', 'div-gpt-ad-1659096504387-0').addService(googletag.pubads());
googletag.pubads().enableSingleRequest();
googletag.pubads().collapseEmptyDivs();
googletag.enableServices();
});
</script>

<div id='div-gpt-ad-1659096504387-0'>
<script>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1659096504387-0'); });
</script>
</div><script>(function(){var js = "window['__CF$cv$params']={r:'748b02153a7d81a5',m:'JP2bzICxhZYVxbBP53G1hKhaPVUlC2U.zsQgNZzo57s-1662842735-0-ASkegF4qKToPye6MZ1b7WtIJeAirETPFl9ZAgCmHocAFNvNmoTxB2JFgjVNfPXvWjpkhQPSNIzUnZgurJRmrcKzqhx6nuSh8D9r545O1YQ4rf/uvf06xK1O/tZmxM1GGnYyvMTKuPGUO4TtKntTLQ/COJb8GxJj3zBO5wLjif8PaGnMczH9xlqRO5zxve8FI6816ahjIHJ4NLx9y/9r18dY=',s:[0xc7290ab131,0x0c6df244b6],u:'/cdn-cgi/challenge-platform/h/g'};var now=Date.now()/1000,offset=14400,ts=''+(Math.floor(now)-Math.floor(now%offset)),_cpo=document.createElement('script');_cpo.nonce='',_cpo.src='/cdn-cgi/challenge-platform/h/g/scripts/alpha/invisible.js?ts='+ts,document.getElementsByTagName('head')[0].appendChild(_cpo);";var _0xh = document.createElement('iframe');_0xh.height = 1;_0xh.width = 1;_0xh.style.position = 'absolute';_0xh.style.top = 0;_0xh.style.left = 0;_0xh.style.border = 'none';_0xh.style.visibility = 'hidden';document.body.appendChild(_0xh);function handler() {var _0xi = _0xh.contentDocument || _0xh.contentWindow.document;if (_0xi) {var _0xj = _0xi.createElement('script');_0xj.nonce = '';_0xj.innerHTML = js;_0xi.getElementsByTagName('head')[0].appendChild(_0xj);}}if (document.readyState !== 'loading') {handler();} else if (window.addEventListener) {document.addEventListener('DOMContentLoaded', handler);} else {var prev = document.onreadystatechange || function () {};document.onreadystatechange = function (e) {prev(e);if (document.readyState !== 'loading') {document.onreadystatechange = prev;handler();}};}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js/v652eace1692a40cfa3763df669d7439c1639079717194" integrity="sha512-Gi7xpJR8tSkrpF7aordPZQlW2DLtzUlZcumS8dMQjwDHEnw9I7ZLyiOj/6tZStRBGtGgN6ceN6cMH8z7etPGlw==" data-cf-beacon='{"rayId":"748b02153a7d81a5","token":"0da52c244fc64e7c8de980e5d83e0a85","version":"2022.8.1","si":100}' crossorigin="anonymous"></script>
</body></html>
