<!DOCTYPE html>
<!--[if IE 9]><html lang="en" class="ie9"><![endif]-->
<html lang="en" dir="ltr">
<head>
<script src="/cdn-cgi/apps/head/x54TqLdHL-_Odnw89NmF9-WSzjw.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PGPJTQ2');</script>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta name="robots" content="index, follow">
<title>Kenyan Obadiah Kinara in US ‘secret’ burial of Dorothy Ongera lawsuit arrested | Nation</title>
<meta name="description" content="
Obadiah Kemari Kinara was at the centre of a row with family of a woman who died while living with him.
">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006"
},
"headline": "Kenyan in US ‘secret’ burial of partner lawsuit arrested",
"image": [
"https://nation.africa/resource/image/3290726/landscape_ratio16x9/1600/900/3c84dce820cd5591b2e2f088316dfaeb/bi/dorothy-bosibori-ongera.jpg",
"https://nation.africa/resource/image/3290726/landscape_ratio3x2/1620/1080/dcd8b94d8340885766e5ff37461b9f41/Qj/dorothy-bosibori-ongera.jpg",
"https://nation.africa/resource/image/3290726/portrait_ratio1x1/1600/1600/fd2de0db8e5c0a5f7892fa279a3818f2/eL/dorothy-bosibori-ongera.jpg"
],
"datePublished": "2021-07-18T04:00:00Z",
"dateModified": "2021-07-17T16:50:15Z",
"author": {
"@type": "Person",
"name": [
"Hilary Kimuyu"
]
},
"publisher": {
"@type": "Organization",
"name": "Nation",
"logo": {
"@type": "ImageObject",
"url": "https://nation.africa/resource/crblob/1909958/2d96fc16039969eac48a6e8f3e055af2/structured-data-logo-png-data.png"
}
} }
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Nation",
"item": "https://nation.africa/kenya"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "News",
"item": "https://nation.africa/kenya/news"
}
,
{
"@type": "ListItem",
"position": 3,
"name": "Diaspora",
"item": "https://nation.africa/kenya/news/diaspora"
}
,
{
"@type": "ListItem",
"position": 4,
"name": "Diaspora News",
"item": "https://nation.africa/kenya/news/diaspora/diaspora-news"
}
]
}
</script>
<meta property="og:site_name" content="Nation" />
<meta property="og:type" content="article" />
<meta property="og:article:published_time" content="2021-07-17T16:50:15Z" />
<meta property="og:title" content="Kenyan Obadiah Kinara in US ‘secret’ burial of Dorothy Ongera lawsuit arrested" />
<meta property="og:description" content="
Obadiah Kemari Kinara was at the centre of a row with family of a woman who died while living with him.
">
<meta property="og:url" content="https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006" />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:image" content="https://nation.africa/resource/image/3290726/landscape_ratio3x2/1200/800/dcd8b94d8340885766e5ff37461b9f41/DA/dorothy-bosibori-ongera.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="fb:app_id" content="174023979648743" />
<meta name="twitter:site" content="@dailynation">
<meta name="twitter:card" content="summary_large_image"> <link rel="canonical" href="https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006">
<meta name="keywords" content="Obadiah Kemari Kinara ,Dorothy Bosibori Ongera,David Ongera ,Texas US,murder,burial,Dennis Nyakundi Mose">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#303030">
<meta name="msapplication-TileColor" content="#ffc40d">
<meta name="theme-color" content="#ffffff">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<link rel="dns-prefetch" href="https://nmg.evolok.net" />
<link rel="preconnect" href="https://nmg.evolok.net" />
<link rel="dns-prefetch" href="https://scripts.nation.africa" />
<link rel="preconnect" href="https://scripts.nation.africa" />
<link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">
<link rel="preload" href="/resource/crblob/491076/8f26773838fb46720f8eee321565ae9c/morion-regular-woff2-data.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/resource/crblob/491082/db592c09b66baa562172b62cac699422/morion-semibold-woff2-data.woff2" as="font" type="font/woff2" crossorigin>
<style>
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 400;
font-display: fallback;
src: local('Roboto'), local('Roboto-Regular'),
url(/resource/crblob/491098/314b3e27a8fc4d780a703b8c6d60eb2e/roboto-regular-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491096/396f61f2524c1a087da7fe4cf6554302/roboto-regular-woff-data.woff) format('woff'),
url(/resource/crblob/491094/84a6341fddcb66cd50fbd315345d9a79/roboto-regular-ttf-data.ttf) format('ttf');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 500;
font-display: fallback;
src: local('Roboto Medium'), local('Roboto-Medium'),
url(/resource/crblob/491092/dcc5e5d97b52622a8acca0d909ab2e27/roboto-medium-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491090/1e49e636e65523052023a5500a51d168/roboto-medium-woff-data.woff) format('woff'),
url(/resource/crblob/491088/b5f1f1704739a86b2300b6e6258ec7ff/roboto-medium-ttf-data.ttf) format('ttf');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 700;
font-display: fallback;
src: local('Roboto Bold'), local('Roboto-Bold'),
url(/resource/crblob/1909918/e5f93140b1b696f3b64ab1e978eb8a92/roboto-bold-woff2-data.woff2) format('woff2'),
url(/resource/crblob/1909916/3eba6b17da134b2434afb8ad6d2c83a4/roboto-bold-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: italic;
font-weight: 400;
font-display: fallback;
src: local('Roboto Italic'), local('Roboto-Italic'),
url(/resource/crblob/491086/c20ba07e455c114af36596dbe6c7eb51/roboto-italic-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491084/5b17397b930cee50ab6c47fd10641c6f/roboto-italic-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: italic;
font-weight: 700;
font-display: fallback;
src: local('Roboto Bold Italic'), local('Roboto-BoldItalic'),
url(/resource/crblob/1909922/f13d361ffda533c07c9a3df7c140c61c/roboto-bolditalic-woff2-data.woff2) format('woff2'),
url(/resource/crblob/1909920/f7308fd720d9f134b6c3b749b90d2edf/roboto-bolditalic-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Morion";
font-style: normal;
font-weight: 300;
font-display: fallback;
src: url(/resource/crblob/1905440/d98f82389286b2e51bb541e2e1094c8e/morion-light-woff2-data.woff2) format("woff2"),
url(/resource/crblob/1905438/9e36b3c52b6e9ce720c63718506804ff/morion-light-woff-data.woff) format("woff");
}
@font-face {
font-family: "Morion";
font-style: normal;
font-weight: 400;
font-display: fallback;
src: url(/resource/crblob/491076/8f26773838fb46720f8eee321565ae9c/morion-regular-woff2-data.woff2) format("woff2"),
url(/resource/crblob/491074/d3d0f9d8049e5cd34b83418007cfd551/morion-regular-woff-data.woff) format("woff"),
url(/resource/crblob/491072/f527ba223329157953b58091c798640e/morion-regular-ttf-data.ttf) format("truetype");
}
@font-face {
font-family: "Morion";
font-weight: 600;
font-display: fallback;
src: url(/resource/crblob/491082/db592c09b66baa562172b62cac699422/morion-semibold-woff2-data.woff2) format("woff2"),
url(/resource/crblob/491080/4b3380c8a84bfbc97119f89918051b90/morion-semibold-woff-data.woff) format("woff"),
url(/resource/crblob/491078/19f56eb45799e6468b58e3207185344a/morion-semibold-ttf-data.ttf) format("truetype");
}
@font-face {
font-family: "Morion";
font-weight: 600;
font-style: italic;
font-display: fallback;
src: url(/resource/crblob/1337618/950d6833f150399efafa7f7783d2176a/morion-semibolditalic-woff2-data.woff2) format("woff2"),
url(/resource/crblob/1337616/3394fd8e0b9b830296cf395bddc1586d/morion-semibolditalic-woff-data.woff) format("woff"),
url(/resource/crblob/1337614/8fc6226dcb8da45c46665b68afc4bcd1/morion-semibolditalic-ttf-data.ttf) format("truetype");
}
</style>
<link href="/resource/themes/nation-2020/css/nation-2020-491114-106.css" rel="stylesheet">
<link rel="stylesheet" href="/resource/themes/nation-2020/css/ev-widgets.min-653026-2.css" media="print" onload="this.media='all'">
<style>
.color-set-color-1 {
background: #FF8D00;
color: #000000;
}
.color-set-color-2 {
background: #FFA100;
color: #000000;
}
.color-set-color-3 {
background: #FFB600;
color: #000000;
}
.color-set-color-4 {
background: #FFC900;
color: #000000;
}
.color-set-color-5 {
background: #FFE600;
color: #000000;
}
.color-set-color-6 {
background: #FFB600;
color: #000000;
}
.color-set-color-7 {
background: #F0F0F0;
color: #000000;
}
.color-set-color-8 {
background: #F8F8F8;
color: #000000;
}
.color-set-color-9 {
background: #E1E1E1;
color: #000000;
}
.color-set-color-10 {
background: #FFF7B8;
color: #000000;
}
/* Styling exceptions for Evolok widgets. Needed because we have no control over their HTML so we can't rely on adding classes like elsewhere. */
/* Paywall button */
.ev-modals .ev-open-modal-paywall-REQUIRE_ENTITLEMENT .ev-button-wrapper .btn,
.ev-modals .ev-open-modal-paywall-REQUIRE_LOGIN_WITH_ENTITLEMENT .ev-button-wrapper .btn {
background-color: #FFA100;
color: #000000;
}
</style>
<script>
var icons = new XMLHttpRequest();
icons.open("GET", "/resource/crblob/499920/04a4c0f8df2bad832b0e93512ac0ae2b/icons-svg-data.svg");
icons.send();
icons.onload = function () {
var d = document.createElement("div");
d.innerHTML = icons.responseText;
d.style = "display: none";
document.body.insertBefore(d, document.body.childNodes[0]);
}
</script>
<script>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</script>
<script>
window.googletag = window.googletag || {cmd: []};
window.windowInnerWidth = window.innerWidth;
window.adDesktopBreakPoint = 1000;
window.adSlots = {};
function shouldRenderAd(isMobileAd) {
return (window.windowInnerWidth <= window.adDesktopBreakPoint && isMobileAd) ||
(window.windowInnerWidth > window.adDesktopBreakPoint && !isMobileAd);
}
googletag.cmd.push(function() {
window.bk_dfp_integration = window.bk_dfp_integration || {};
window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {};
if (typeof bk_dfp_integration.functions.sendDfp === "function") {
bk_dfp_integration.functions.sendDfp();
}
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
if (window.location.pathname.split( '/' )[2]) {
googletag.pubads().setTargeting('url1', window.location.pathname.split( '/' )[2]);
}
if (window.location.pathname.split( '/' )[3]) {
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[3]);
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-1'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-1", [[320,50], [320,100], [300, 250]], "mobile-article-ad-1")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-1'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-1", [[728,90], [970,90], [300, 250]], "desktop-article-ad-1")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-2'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-2", [[320,50], [320,100], [300, 250]], "mobile-article-ad-2")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-2'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-2", [[728,90], [970,90], [300, 250]], "desktop-article-ad-2")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-3'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-3", [[728,90], [970,90], [300, 250]], "desktop-article-ad-3")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-3'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-3", [[320,50], [320,100], [300, 250]], "mobile-article-ad-3")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-above-navigation'] = googletag
.defineSlot("/1010816/Z-DN-728x90-ArticleTop", [[728,90], [970,90]], "desktop-article-above-navigation")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-top'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-Article-Strip", [[320,50], [320,100]], "mobile-article-ad-top")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
googletag
.defineOutOfPageSlot('/1010816/Z-DN-RoadBlock','div-gpt-ad-1600501942202-0')
.addService(googletag.pubads());
googletag.enableServices();
});
</script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PGPJTQ2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id='div-gpt-ad-1600501942202-0' style="position: absolute; top: 0;">
<script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600501942202-0'); });
</script>
</div>
<section class="page-content detail-content">
<header class="page-grid-header">
<header data-page-header="true" class="page-header">
<div class="page-header_ad color-set-color-1" data-page-header-ad="true">
<div class="ad-leaderboard_wrap">
<div id="desktop-article-above-navigation" class="ad-leaderboard">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-above-navigation");
});
}
</script>
</div>
</div>
</div>
<nav class="main-nav color-set-color-1" data-main-nav="true">
<div class="grid-container">
<div class="main-nav_buttons">
<button class="main-nav_menu-btn" data="open-menu" aria-haspopup="true" aria-controls="menu" aria-expanded="false" aria-label="Toggle menu">
<svg class="icon-menu-button" aria-hidden="true" focusable="false">
<use xlink:href="#icon-menu-button"></use>
</svg>
<svg class="icon-close" aria-hidden="true" focusable="false">
<use xlink:href="#icon-close"></use>
</svg>
<span class="main-nav_btn-close-text">Close</span>
<span class="main-nav_btn-menu-text">Menu</span>
</button>
<a href="/kenya/search" class="main-nav_search-button" aria-label="Search page">
<svg class="icon-search" aria-hidden="true" focusable="false">
<use xlink:href="#icon-search"></use>
</svg>
<span>Search</span>
</a>
</div>
<h2 class="logo">
<a href="/kenya" aria-label="Homepage">
<svg class="logo-svg" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 146 30">
<path fill-rule="evenodd" d="M108.648553,27.0221865 C103.845659,28.8163987 97.9344051,24.8691318 95.4446945,18.2054662 C92.9550804,11.540836 94.8282958,4.68424437 99.6302251,2.89003215 C104.432154,1.09572347 110.344373,5.04308682 112.83418,11.7066559 C115.323794,18.3713826 113.449518,25.2279743 108.648553,27.0221865 M104.138907,0 C112.130868,0 118.609325,6.69646302 118.609325,14.9565916 C118.609325,23.2157556 112.130868,29.9122186 104.138907,29.9122186 C96.14791,29.9122186 89.6694534,23.2157556 89.6694534,14.9565916 C89.6694534,6.69646302 96.14791,0 104.138907,0 Z M126.807698,0.490987138 L143.688727,21.2444277 L143.697987,0.507578778 L145.859145,0.507578778 L145.859145,29.438865 L142.724096,29.438865 L125.843068,8.68436334 L125.843164,29.4464855 L123.67265,29.438865 L123.67265,0.490987138 L126.807698,0.490987138 Z M7.09228296,0.478446945 L22.1453376,19.060119 L22.1453376,3.33095498 L20.2160772,0.973302251 L20.2160772,0.490987138 L26.2450161,0.490987138 L26.2450161,0.973302251 L24.3157556,3.33095498 L24.3157556,29.4298939 L22.8688103,29.4298939 L4.34974277,6.53053698 L4.29967846,6.46301286 L4.29967846,26.5900225 L6.22893891,28.9475788 L6.22893891,29.4298939 L0.2,29.4298939 L0.2,28.9475788 L2.12926045,26.5900225 L2.12926045,3.55667846 L0.2,0.973302251 L0.2,0.490987138 L7.09228296,0.478446945 Z M76.4057878,0.477491961 L76.4057878,5.55530547 L66.2771704,5.55530547 L66.2771704,26.5900322 L68.2064309,28.9475884 L68.2064309,29.4299035 L62.177492,29.4299035 L62.177492,28.9475884 L64.1067524,26.5900322 L64.1067524,5.55530547 L53.978135,5.55530547 L53.978135,0.477491961 L76.4057878,0.477491961 Z M43.1260064,0.475562701 L53.9780965,29.4299035 L48.1903151,29.4299035 L45.2068103,21.4717042 L34.0362958,21.4717042 L31.0681286,29.4299035 L31.0681286,29.4212219 L28.6565531,29.4212219 L38.4118585,3.34533762 L39.4836592,0.479421222 L41.8681286,0.477491961 L43.1260064,0.475562701 Z M84.3638907,0.490996785 L84.3639871,29.4221865 L82.1935691,29.4221865 L82.1935691,0.490996785 L84.3638907,0.490996785 Z M39.6080965,6.53633441 L34.9362958,19.0601286 L44.3029518,19.0601286 L39.6080965,6.53633441 Z" />
</svg>
</a>
</h2>
<div class="main-nav_account">
<div class="account-menu" data="account-menu">
<button type="button" class="account-menu_login-btn" data="log-in">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="not-loggedIn">
<span class="profile-btn">
<span class="profile-btn_name">Log in</span>
<span class="profile-btn_icon color-set-color-3">
<svg class="icon-user" aria-hidden="true" focusable="false">
<use xlink:href="#icon-user"></use>
</svg>
</span>
</span>
</ev-profile-when>
</ev-profile>
</button>
<button class="account-menu_button" data="toggle-account-menu" aria-haspopup="true" aria-controls="account-menu" aria-expanded="false" aria-label="Open account menu">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="available">
<span class="profile-btn">
<span class="profile-btn_name">
{{profile.name ? profile.name : profile.email.substr(0,profile.email.indexOf("@"))}}
</span>
<span class="profile-btn_icon color-set-color-3">
<svg class="icon-user" aria-hidden="true" focusable="false">
<use xlink:href="#icon-user"></use>
</svg>
</span>
</span>
</ev-profile-when>
<ev-profile-when state="not-loggedIn">
<span class="default-btn color-set-color-3">
Subscribe
</span>
</ev-profile-when>
</ev-profile>
</button>
<nav id="account-menu" class="account-menu_popup">
<svg xmlns="http://www.w3.org/2000/svg" width="30" height="15" viewBox="0 0 30 15" class="account-menu_popup-triangle">
<path fill="#F8F8F8" fill-rule="evenodd" d="M1327,49 C1327,59 1332,64 1342,64 L1312,64 C1322,64 1327,59 1327,49 Z" transform="translate(-1312 -49)" />
</svg>
<div class="account-menu_popup-inner">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="available">
<a href="/kenya/account" class="account-menu_popup-header">My account</a>
<ul>
<li>
<a href="/kenya/account#details" class="account-menu_popup-link">Personal details</a>
</li>
<li>
<a href="/kenya/account#password" class="account-menu_popup-link">Change password</a>
</li>
<li>
<a href="/kenya/account#purchases" class="account-menu_popup-link">Purchases</a>
</li>
<li>
<a href="/kenya/account#referral" class="account-menu_popup-link">Refer a friend</a>
</li>
<li>
<button class="account-menu_popup-link" data="sign-out">Sign out</button>
</li>
</ul>
</ev-profile-when>
<ev-profile-when state="not-loggedIn">
<div class="account-menu_signin-register">
<p class="account-menu_signin-text">Already signed up? <button type="button" data="log-in-popup">Log in</button></p>
<button type="button" data="register" class="default-btn default-btn-no-color">Sign up</button>
</div>
</ev-profile-when>
</ev-profile>
</div>
</nav>
</div> </div>
</div>
</nav>
<nav class="sub-nav color-set-color-2" data-sub-nav="true">
<div class="grid-container">
<h3 class="sub-nav_section-title" data-sub-nav-header="true">
<a href="/kenya/news/diaspora">
<span class="sub-nav_section-title-desktop">Diaspora</span>
<span class="sub-nav_section-title-mobile">Diaspora News</span>
</a>
</h3>
</div>
</nav>
<nav class="mega-menu" data-mega-menu="true" id="menu">
<section class="mega-menu_section clearfix color-set-color-8">
<div class="grid-container">
<div class="col-1-1">
<div class="mega-menu_search">
<a href="/kenya/search" class="mega-menu_search-button" aria-label="Search page">
<svg class="icon-search" aria-hidden="true" focusable="false">
<use xlink:href="#icon-search"></use>
</svg>
<span>Search</span>
</a>
</div>
</div>
<nav role="navigation" aria-label="Site index" class="categories-nav col-1-1">
<ul class="nested-cols categories-nav_categories">
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category current-section">
<a href="/kenya/news" class="categories-nav_link categories-nav_title">
News
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/news/national" class="categories-nav_link current-section">National</a>
</li>
<li>
<a href="/kenya/news/africa" class="categories-nav_link current-section">Africa</a>
</li>
<li>
<a href="/kenya/news/world" class="categories-nav_link current-section">World</a>
</li>
<li>
<a href="/kenya/news/gender" class="categories-nav_link current-section">Gender</a>
</li>
<li>
<a href="/kenya/news/health" class="categories-nav_link current-section">Health</a>
</li>
<li>
<a href="/kenya/news/tech" class="categories-nav_link current-section">Tech</a>
</li>
<li>
<a href="/kenya/news/newsplex" class="categories-nav_link current-section">Newsplex</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/counties" class="categories-nav_link categories-nav_title">
Counties
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/counties/nairobi-metro" class="categories-nav_link ">Nairobi Metro</a>
</li>
<li>
<a href="/kenya/counties/coast" class="categories-nav_link ">Coast</a>
</li>
<li>
<a href="/kenya/counties/mountain" class="categories-nav_link ">Mountain</a>
</li>
<li>
<a href="/kenya/counties/lake-region" class="categories-nav_link ">Lake Region</a>
</li>
<li>
<a href="/kenya/counties/rift-valley" class="categories-nav_link ">Rift Valley</a>
</li>
<li>
<a href="/kenya/counties/northern" class="categories-nav_link ">Northern</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/business" class="categories-nav_link categories-nav_title">
Business
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/business/companies" class="categories-nav_link ">Companies</a>
</li>
<li>
<a href="/kenya/business/finance-and-markets" class="categories-nav_link ">Finance and Markets</a>
</li>
<li>
<a href="/kenya/business/seeds-of-gold" class="categories-nav_link ">Seeds of Gold</a>
</li>
<li>
<a href="/kenya/business/enterprise" class="categories-nav_link ">Enterprise</a>
</li>
<li>
<a href="/kenya/business/shillings-sense" class="categories-nav_link ">Shillings &amp; Sense</a>
</li>
<li>
<a href="/kenya/business/leadership" class="categories-nav_link ">Leadership</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/blogs-opinion" class="categories-nav_link categories-nav_title">
Opinion
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/blogs-opinion/editorials" class="categories-nav_link ">Editorials</a>
</li>
<li>
<a href="/kenya/blogs-opinion/opinion" class="categories-nav_link ">Our Columnists</a>
</li>
<li>
<a href="/kenya/blogs-opinion/blogs" class="categories-nav_link ">Guest Blogs</a>
</li>
<li>
<a href="/kenya/blogs-opinion/letters" class="categories-nav_link ">Letters to the Editor</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cutting-edge" class="categories-nav_link ">Cutting Edge</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cartoons" class="categories-nav_link ">Cartoons</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/sports" class="categories-nav_link categories-nav_title">
Sports
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/sports/football" class="categories-nav_link ">Football</a>
</li>
<li>
<a href="/kenya/sports/athletics" class="categories-nav_link ">Athletics</a>
</li>
<li>
<a href="/kenya/sports/rugby" class="categories-nav_link ">Rugby</a>
</li>
<li>
<a href="/kenya/sports/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/sports/talkup" class="categories-nav_link ">TalkUP!</a>
</li>
<li>
<a href="/kenya/sports/other-sports" class="categories-nav_link ">Other Sports</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/life-and-style" class="categories-nav_link categories-nav_title">
Life &amp; Style
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/life-and-style/culture" class="categories-nav_link ">Culture</a>
</li>
<li>
<a href="/kenya/life-and-style/family" class="categories-nav_link ">Family</a>
</li>
<li>
<a href="/kenya/life-and-style/relationships" class="categories-nav_link ">Relationships</a>
</li>
<li>
<a href="/kenya/life-and-style/art-books" class="categories-nav_link ">Art &amp; Books</a>
</li>
<li>
<a href="/kenya/life-and-style/travel" class="categories-nav_link ">Travel</a>
</li>
<li>
<a href="/kenya/life-and-style/wellness" class="categories-nav_link ">Wellness</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/newsletters" class="categories-nav_link categories-nav_title">
Newsletters
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/audio" class="categories-nav_link categories-nav_title">
Audio
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/puzzles" class="categories-nav_link categories-nav_title">
Puzzles
</a>
</li>
</ul>
</nav> </div>
<nav class="channels-nav">
<ul class="grid-container">
<li class="col-1-1 medium-col-1-3">
<h2 class="channels-nav_heading">Nation ePaper</h2>
<ul>
<li class="channels-nav_link-item">
<a href="https://newsstand.nationmedia.com/" target="_blank" rel="noopener">Nation</a>
</li>
</ul>
</li>
</ul>
</nav> </section>
</nav>
<div class="breaking-news">
<div class="container">
<div class="breaking-news-container" data-separator="" data-fragments-link="/ajax/breaking-news/kenya">
</div>
</div>
</div></header> </header>
<div class="article-page" data-article-content>
<header class="article-header">
<div class="grid-container-small">
<div class="col-1-1">
<div class="ad-mobile-leaderboard_wrap">
<div id="mobile-article-ad-top" class="ad-mobile-leaderboard">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-top");
});
}
</script>
</div>
</div>
<h1 class="title-medium">Kenyan Obadiah Kinara in US ‘secret’ burial of Dorothy Ongera lawsuit arrested</h1>
<time class="date" datetime="2021-07-18T04:00:00Z">
Sunday, July 18, 2021
</time>
<figure class="article-picture">
<div class="lazy-img-container img-space_landscape_ratio2x1">
<img src="/resource/image/3290726/landscape_ratio2x1/320/160/cdf92a1e26d039eeb4299fcae9a760e9/kc/dorothy-bosibori-ongera.jpg" srcset="
/resource/image/3290726/landscape_ratio2x1/320/160/cdf92a1e26d039eeb4299fcae9a760e9/kc/dorothy-bosibori-ongera.jpg 320w,
/resource/image/3290726/landscape_ratio2x1/640/320/cdf92a1e26d039eeb4299fcae9a760e9/iX/dorothy-bosibori-ongera.jpg 640w,
/resource/image/3290726/landscape_ratio2x1/720/360/cdf92a1e26d039eeb4299fcae9a760e9/HW/dorothy-bosibori-ongera.jpg 720w,
/resource/image/3290726/landscape_ratio2x1/960/480/cdf92a1e26d039eeb4299fcae9a760e9/aD/dorothy-bosibori-ongera.jpg 960w,
/resource/image/3290726/landscape_ratio2x1/1280/640/cdf92a1e26d039eeb4299fcae9a760e9/EF/dorothy-bosibori-ongera.jpg 1280w
" sizes="(min-width: 820px) 820px, (min-width: 630px) 630px, 100vw" width="100" height="100" alt="Dorothy Bosibori Ongera " />
</div>
<figcaption class="article-picture_caption">
<p>Dorothy Bosibori Ongera (left) and Obadiah Kinara in a file picture in Dallas, Texas. Dorothy died in an accidental drowning on December 17, 2020. </p>
<div class="article-picture_copyright"><span class="article-picture_credit">Photo credit:</span> Pool</div>
</figcaption>
</figure>
</div>
</div>
</header>
<div class="article-content xxx">
<div class="grid-container-small">
<div class="col-1-1">
<div class="article-authors">
<div class="article-authors_inner clearfix">
<div class="article-authors_imgs clearfix">
<figure class="article-authors_img lazy-img-container" style="z-index: 1;">
<a href="/kenya/hilary-kimuyu-5146">
<img data-src="/resource/image/95774/portrait_ratio1x1/60/60/823bf775bcdec75a480f53073efaf1c2/CE/new-logo1.jpg" data-srcset="
/resource/image/95774/portrait_ratio1x1/60/60/823bf775bcdec75a480f53073efaf1c2/CE/new-logo1.jpg 60w,
/resource/image/95774/portrait_ratio1x1/120/120/823bf775bcdec75a480f53073efaf1c2/Cx/new-logo1.jpg 120w
" sizes="60px" alt="" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</a>
</figure>
</div>
<div class="article-authors_texts">
<p class="article-authors_authors clearfix">
<span>By&nbsp;</span>
<a href="/kenya/hilary-kimuyu-5146">Hilary Kimuyu</a>
</p>
<p class="article-authors_org">Nation Media Group</p>
</div>
</div>
</div>
<div class="articles-left-notifier" data-articles-left-notifier hidden>
<aside class="promotion-banner color-set-color-5">
<div class="promotion-banner_texts">
<h2>Thank you for reading Nation.Africa</h2>
<p data-articles-left-message></p>
<a href="/kenya/subscribe" class="default-btn">
Show plans
</a>
</div>
</aside>
</div>
<section>
<div class="text-block">
<div class="datawall-content paragraph-wrapper" data="datawall-content">
<p> A Kenyan man who has been at the centre of controversy after he ‘secretly’ buried his partner in the US in December last year has been arrested.</p> </div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-1" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-1");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-1']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-1" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-1");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-1']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>According to police records, Obadiah Kemari Kinara was booked on Sunday, July 11, 2021, into the Tarrant County Jail system in or around Dallas – Ft Worth, TX.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>He was arrested for suspicion of “injury to a child, elderly or disabled individual with bodily injury” offence, according to CrimeInformer, a state agency.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Mr Kinara was arrested at a court of law in Texas. His bail has been set at Sh1.3 million ($12,000).</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>He is presumed innocent until proven guilty in a court of law.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The man was last year at the centre of a controversy surrounding the death of his partner Dorothy Bosibori Ongera, 35.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Dorothy, a mother of six, died in Texas on December 17, 2020. Her lifeless body was found in a bathtub at her house in Dallas.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<h2>Foul play</h2> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Kinara denied having a hand in her death but her family demanded an independent autopsy after Tarrant County Medical Examiner’s office ruled out foul play, ruling the incident as accidental drowning.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>In March, Dorothy’s father David Ongera obtained an order from a Texas court to exhume his daughter’s body after Kinara buried her in a public cemetery on December 28, 2020.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The judge barred parties from interfering with the remains until the matter is determined.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“After hearing and reviewing the evidence and considering the argument of counsel, the court grants the motion to exhume the body.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“However, because this court has not yet adjudicated the person with the right to control the disposition of the remains of Dorothy Ongera, after exhumation there is not yet any person with the powers to direct the cemetery as to the disposition, including whether or not yet any autopsy shall be performed,” ordered Justice Brooke Allen of Tarrant County in Texas.</p> </div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-2" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-2");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-2']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-2" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-2");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-2']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<h2>Right to bury</h2> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>A hearing to determine who has the right to bury the deceased will commence on March 23.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The family questioned the motive of Ms Bosibori’s partner for secretly burying her body, saying he had no legal rights to do so as he was neither her next of kin nor husband.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Kinara, a registered nurse, insisted that Dorothy was his wife and he had the right to bury her but her family refuted these claims, saying their union was not legally recognised.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Ms Bosibori was living with Kinara, with whom she had three children.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<h2>Estranged husband</h2> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The father of the other children is her estranged husband, Dennis Nyakundi Mose, who lives in Kenya.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“I loved my wife, and I’ve been deeply hurt and affected by the social media campaign orchestrated by my in-laws to create the impression that I had something to do with the death.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“I believe some people are doing this because they are targeting my children and the insurance payouts,” Kinara told the <em>Sunday Nation</em> in February.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p><em>hkimuyu@ke.nationmedia.com</em></p> </div>
</div>
</section>
<aside class="promotion-banner color-set-color-5">
<div class="promotion-banner_texts">
<h2>Nation. Empower Africa.</h2>
<p>
<strong>We come to you.</strong>
We are always looking for ways to improve our stories. Let us know what you liked and what we can improve on.
</p>
<a href="https://docs.google.com/forms/d/e/1FAIpQLSfOOJA0WUAChH42ijf4Xj1kVFuxGzwLEWYMpfHmzxqiWTh_ow/viewform?usp=pp_url&amp;entry.582792058=Kenyan%20Obadiah%20Kinara%20in%20US%20%E2%80%98secret%E2%80%99%20burial%20of%20Dorothy%20Ongera%20lawsuit%20arrested" class="default-btn" target="_blank" rel="nofollow noopener">I&#39;ve got feedback!</a>
</div>
</aside>
<aside>
<ul class="social-share-list">
<li>
<div class="fb-share-button">
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006" rel="noopener noreferrer" aria-label="Share on Facebook">
<svg class="icon-social-facebook" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-facebook"></use>
</svg>
</a>
</div>
</li>
<li>
<a target="_blank" class="twitter-share-button" href="https://twitter.com/intent/tweet?text=Kenyan%20Obadiah%20Kinara%20in%20US%20%E2%80%98secret%E2%80%99%20burial%20of%20Dorothy%20Ongera%20lawsuit%20arrested&url=https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006" " rel="noopener noreferrer" aria-label="Share on Twitter">
<svg class="icon-social-twitter" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-twitter"></use>
</svg>
</a>
</li>
<li>
<a target="_blank" class="whatsapp-share-button" href="https://wa.me/?text=https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006" rel="noopener noreferrer" aria-label="Share on Whatsapp">
<svg class="icon-social-whatsapp" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-whatsapp"></use>
</svg>
</a>
</li>
<li>
<a target="_blank" class="email-share-button" href="mailto:?subject=Kenyan Obadiah Kinara in US ‘secret’ burial of Dorothy Ongera lawsuit arrested&body=https://nation.africa/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006" rel="noopener noreferrer" aria-label="Share via email">
<svg class="icon-social-email" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-email"></use>
</svg>
</a>
</li>
</ul>
</aside>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-3" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-3");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-3']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-3" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-3");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-3']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
</div>
</div>
<script>
(function() { // DON'T EDIT BELOW THIS LINE - unless "dailynation" changes on Disqus settings
var d = document, s = d.createElement('script');
s.src = 'https://dailynation.disqus.com/embed.js';
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div class="grid-container-small disqus-block is-hidden" data-disqus-comments>
<div class="col-1-1">
<h3 class="title-small">Join the discussion</h3>
<div class="disqus-block-account">
<button type="button" class="login-btn" data-log-in-disqus>
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="not-loggedIn">
<span>Login with your Nation account</span>
</ev-profile-when>
</ev-profile>
</button>
<a href="/kenya/account" class="login-btn">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="available">
<span class="profile-btn_name">
{{ profile.name ? "Commenting as "+profile.name : "Please add your name to your Nation profile to comment" }}
</span>
</ev-profile-when>
</ev-profile>
</a>
</div>
<div id="disqus_thread"></div>
</div>
</div>
</div>
<section class="teasers-row">
<div class="grid-container">
<div class="col-1-1 medium-col-1-2 large-col-2-3">
<section class="nested-cols">
<div class="col-1-1">
<header class="teasers-row_header">
<h2 class="section-label" style="background: #FFB600; color:#000000;">
Editor&#39;s picks
</h2>
</header>
</div>
<ul>
<li class="col-1-1 large-col-1-2">
<a href="/kenya/news/diaspora/diaspora-news/body-kenyan-woman-buried-secretly-lover-us-exhumed-3318040" aria-label="Body of Kenyan woman buried ‘secretly’ by lover in US to be exhumed" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3290726/landscape_ratio3x2/300/200/dcd8b94d8340885766e5ff37461b9f41/Fy/dorothy-bosibori-ongera.jpg" data-srcset="
/resource/image/3290726/landscape_ratio3x2/300/200/dcd8b94d8340885766e5ff37461b9f41/Fy/dorothy-bosibori-ongera.jpg 300w,
/resource/image/3290726/landscape_ratio3x2/600/400/dcd8b94d8340885766e5ff37461b9f41/wL/dorothy-bosibori-ongera.jpg 600w,
/resource/image/3290726/landscape_ratio3x2/900/600/dcd8b94d8340885766e5ff37461b9f41/MA/dorothy-bosibori-ongera.jpg 900w,
/resource/image/3290726/landscape_ratio3x2/1200/800/dcd8b94d8340885766e5ff37461b9f41/DA/dorothy-bosibori-ongera.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Dorothy Bosibori Ongera " width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Body of Kenyan woman buried ‘secretly’ by lover in US to be exhumed
</h3>
<p class="teaser-image-large_paragraph text-block">
The death has since become an online sensation because of the circumstances surrounding her sudden death and burial.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Diaspora News</span>
<span class="date">
Mar 10
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 large-col-1-2">
<a href="/kenya/news/diaspora/diaspora-news/i-didn-t-kill-my-kenyan-wife-texas-man-insists-3290720" aria-label="I didn’t kill my Kenyan wife, Texas man insists" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3290726/landscape_ratio3x2/300/200/dcd8b94d8340885766e5ff37461b9f41/Fy/dorothy-bosibori-ongera.jpg" data-srcset="
/resource/image/3290726/landscape_ratio3x2/300/200/dcd8b94d8340885766e5ff37461b9f41/Fy/dorothy-bosibori-ongera.jpg 300w,
/resource/image/3290726/landscape_ratio3x2/600/400/dcd8b94d8340885766e5ff37461b9f41/wL/dorothy-bosibori-ongera.jpg 600w,
/resource/image/3290726/landscape_ratio3x2/900/600/dcd8b94d8340885766e5ff37461b9f41/MA/dorothy-bosibori-ongera.jpg 900w,
/resource/image/3290726/landscape_ratio3x2/1200/800/dcd8b94d8340885766e5ff37461b9f41/DA/dorothy-bosibori-ongera.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Dorothy Bosibori Ongera " width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
I didn’t kill my Kenyan wife, Texas man insists
</h3>
<p class="teaser-image-large_paragraph text-block">
Woman’s father and Kenyan ‘husband’ in social media campaign against ‘interloper’. </p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Diaspora News</span>
<span class="date">
Feb 13
</span>
</aside>
</div>
</article>
</a> </li>
</ul>
</section>
</div>
<div class="col-1-1 medium-col-1-2 large-col-1-3">
<section class="teasers-row_category nested-cols">
<div class="col-1-1">
<header class="teasers-row_header">
<h2 class="section-label" style="background: #FFB600; color:#000000;">
<a href="/kenya/news">More from News</a>
</h2>
</header>
<ol class="article-collection">
<li>
<a href="/kenya/news/politics/odm-says-talks-on-despite-jubilee-loss-in-kiambaa--3477086" aria-label="ODM says talks on despite Jubilee loss in Kiambaa " class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
ODM says talks on despite Jubilee loss in Kiambaa
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Politics</span>
<span class="date">
20 min ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/news/politics/resign-uhuru-allies-tell-raphael-tuju-david-murathe-after-kiambaa-defeat-3477120" aria-label="Uhuru allies now go for Tuju, Murathe" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
Uhuru allies now go for Tuju, Murathe
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Politics</span>
<span class="date">
20 min ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/news/chief-justice-martha-koome-gets-tough-as-her-reign-takes-shape-3477058" aria-label="Koome gets tough as her reign takes shape" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
Koome gets tough as her reign takes shape
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">News</span>
<span class="date">
1 hour ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/news/africa/zuma-graft-trial-to-resume-despite-deadly-protests-3477196" aria-label="Zuma graft trial to resume despite deadly protests" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
Zuma graft trial to resume despite deadly protests
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Africa</span>
<span class="date">
1 hour ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/news/politics/william-ruto-nyanza-tour-hangs-in-the-balance-after-key-allies-develop-cold-feet--3477094" aria-label="Why Ruto Nyanza tour hangs in the balance " class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
Why Ruto Nyanza tour hangs in the balance
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Politics</span>
<span class="date">
1 hour ago
</span>
</aside>
</article>
</a> </li>
</ol> </div>
</section> </div>
</div>
</section>
<section class="teasers-row">
<header class="teasers-row_header grid-container">
<div class="col-1-1 clearfix">
<h2 class="section-label" style="background: #FFB600; color:#000000;">
<a href="/kenya">In the headlines</a>
</h2>
<nav class="subcategories-list">
<ul>
<li>
<a href="/kenya/news" class="link-more ">
News
</a>
</li>
<li>
<a href="/kenya/counties" class="link-more ">
Counties
</a>
</li>
<li>
<a href="/kenya/business" class="link-more ">
Business
</a>
</li>
<li>
<a href="/kenya/blogs-opinion" class="link-more ">
Opinion
</a>
</li>
<li>
<a href="/kenya/sports" class="link-more ">
Sports
</a>
</li>
<li>
<a href="/kenya/life-and-style" class="link-more ">
Life &amp; Style
</a>
</li>
<li>
<a href="/kenya/newsletters" class="link-more ">
Newsletters
</a>
</li>
<li>
<a href="/kenya/audio" class="link-more ">
Audio
</a>
</li>
<li>
<a href="/kenya/puzzles" class="link-more ">
Puzzles
</a>
</li>
</ul>
</nav>
</div>
</header>
<div class="teasers-row_nested-row teasers-row_nested-row-3-col">
<ul class="grid-container">
<li class="col-1-1 large-col-1-3">
<a href="/kenya/news/politics/resign-uhuru-allies-tell-raphael-tuju-david-murathe-after-kiambaa-defeat-3477120" aria-label="Uhuru allies now go for Tuju, Murathe" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
medium-col-1-2 large-col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3477126/landscape_ratio3x2/300/200/10faca81f42c86d542a3421760aec715/jP/tuju-murathe.jpg" data-srcset="
/resource/image/3477126/landscape_ratio3x2/300/200/10faca81f42c86d542a3421760aec715/jP/tuju-murathe.jpg 300w,
/resource/image/3477126/landscape_ratio3x2/600/400/10faca81f42c86d542a3421760aec715/QQ/tuju-murathe.jpg 600w,
/resource/image/3477126/landscape_ratio3x2/900/600/10faca81f42c86d542a3421760aec715/cV/tuju-murathe.jpg 900w,
/resource/image/3477126/landscape_ratio3x2/1200/800/10faca81f42c86d542a3421760aec715/pN/tuju-murathe.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="David Murathe" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
medium-col-1-2 large-col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
Uhuru allies now go for Tuju, Murathe
</h3>
<p class="teaser-image-large_paragraph text-block">
Secretariat is blamed for being elitist and messing up the party’s image.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Politics</span>
<span class="date">
20 min ago
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-3">
<a href="/kenya/counties/siaya/13-killed-in-siaya-fuel-tanker-explosion-3477170" aria-label="13 killed in Siaya fuel tanker explosion" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3477172/landscape_ratio3x2/300/200/6284439483c0d3915e6596cb45fd47f1/gw/truck.jpg" data-srcset="
/resource/image/3477172/landscape_ratio3x2/300/200/6284439483c0d3915e6596cb45fd47f1/gw/truck.jpg 300w,
/resource/image/3477172/landscape_ratio3x2/600/400/6284439483c0d3915e6596cb45fd47f1/wV/truck.jpg 600w,
/resource/image/3477172/landscape_ratio3x2/900/600/6284439483c0d3915e6596cb45fd47f1/fu/truck.jpg 900w,
/resource/image/3477172/landscape_ratio3x2/1200/800/6284439483c0d3915e6596cb45fd47f1/uu/truck.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Fuel tanker explosion Siaya" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
13 killed in Siaya fuel tanker explosion
</h3>
<p class="teaser-image-large_paragraph text-block">
Chacha says residents took advantage of the absence of police officers to siphon petrol.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Siaya</span>
<span class="date">
26 min ago
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-3">
<a href="/kenya/counties/no-cremation-for-caroline-kangogo-3476978" aria-label="Kin: No cremation for Caroline Kangogo " class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3472202/landscape_ratio3x2/300/200/65a9458caf47e2abf5653cd9821a698a/an/kangogo.jpg" data-srcset="
/resource/image/3472202/landscape_ratio3x2/300/200/65a9458caf47e2abf5653cd9821a698a/an/kangogo.jpg 300w,
/resource/image/3472202/landscape_ratio3x2/600/400/65a9458caf47e2abf5653cd9821a698a/SM/kangogo.jpg 600w,
/resource/image/3472202/landscape_ratio3x2/900/600/65a9458caf47e2abf5653cd9821a698a/RV/kangogo.jpg 900w,
/resource/image/3472202/landscape_ratio3x2/1200/800/65a9458caf47e2abf5653cd9821a698a/tB/kangogo.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Caroline Kangogo" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
Kin: No cremation for Caroline Kangogo
</h3>
<p class="teaser-image-large_paragraph text-block">
Family says it will accord its infamous daughter a Christian send-off.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Counties</span>
<span class="date">
4 hours ago
</span>
</aside>
</div>
</article>
</a> </li>
</ul>
<div class="grid-container border-wrapper">
<div class="col-1-1">
<hr />
</div>
</div>
</div> </section>
<div id="taboola-below-article-thumbnails1"></div>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({
mode: 'alternating-thumbnails-a',
container: 'taboola-below-article-thumbnails1',
placement: 'Below Article Thumbnails1',
target_type: 'mix'
});
</script>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1714",
postid: "new-3477006",
maincontent: ".article-content",
title: "Kenyan Obadiah Kinara in US ‘secret’ burial of Dorothy Ongera lawsuit arrested",
pubdate: "2021-07-18 07:00:00",
authors: "Hilary Kimuyu",
sections: "Diaspora News",
tags: "Investigations, Obadiah Kemari Kinara ,Dorothy Bosibori Ongera,David Ongera ,Texas US,murder,burial,Dennis Nyakundi Mose",
comments: ""
};
/* CONFIGURATION END */
(function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
</script></div>
<aside class="error-message-block" style="display: none;" role="alert" data-article-error>
<h1 class="title-small">Oops</h1>
<h2 class="title-normal">
We're sorry, we couldn't load the article
</h2>
<p>
If you have an Ad-blocker please disable it and reload the page or try again later.
</p>
<button type="button" class="default-btn" onclick="window.location.reload()">Reload page</button>
</aside>
<footer class="page-footer color-set-color-8" data="page-footer">
<div class="page-footer_top grid-container">
<nav role="navigation" aria-label="Site index" class="categories-nav col-1-1">
<ul class="nested-cols categories-nav_categories">
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/news" class="categories-nav_link categories-nav_title">
News
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/news/national" class="categories-nav_link ">National</a>
</li>
<li>
<a href="/kenya/news/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/news/world" class="categories-nav_link ">World</a>
</li>
<li>
<a href="/kenya/news/gender" class="categories-nav_link ">Gender</a>
</li>
<li>
<a href="/kenya/news/health" class="categories-nav_link ">Health</a>
</li>
<li>
<a href="/kenya/news/tech" class="categories-nav_link ">Tech</a>
</li>
<li>
<a href="/kenya/news/newsplex" class="categories-nav_link ">Newsplex</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/counties" class="categories-nav_link categories-nav_title">
Counties
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/counties/nairobi-metro" class="categories-nav_link ">Nairobi Metro</a>
</li>
<li>
<a href="/kenya/counties/coast" class="categories-nav_link ">Coast</a>
</li>
<li>
<a href="/kenya/counties/mountain" class="categories-nav_link ">Mountain</a>
</li>
<li>
<a href="/kenya/counties/lake-region" class="categories-nav_link ">Lake Region</a>
</li>
<li>
<a href="/kenya/counties/rift-valley" class="categories-nav_link ">Rift Valley</a>
</li>
<li>
<a href="/kenya/counties/northern" class="categories-nav_link ">Northern</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/business" class="categories-nav_link categories-nav_title">
Business
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/business/companies" class="categories-nav_link ">Companies</a>
</li>
<li>
<a href="/kenya/business/finance-and-markets" class="categories-nav_link ">Finance and Markets</a>
</li>
<li>
<a href="/kenya/business/seeds-of-gold" class="categories-nav_link ">Seeds of Gold</a>
</li>
<li>
<a href="/kenya/business/enterprise" class="categories-nav_link ">Enterprise</a>
</li>
<li>
<a href="/kenya/business/shillings-sense" class="categories-nav_link ">Shillings &amp; Sense</a>
</li>
<li>
<a href="/kenya/business/leadership" class="categories-nav_link ">Leadership</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/blogs-opinion" class="categories-nav_link categories-nav_title">
Opinion
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/blogs-opinion/editorials" class="categories-nav_link ">Editorials</a>
</li>
<li>
<a href="/kenya/blogs-opinion/opinion" class="categories-nav_link ">Our Columnists</a>
</li>
<li>
<a href="/kenya/blogs-opinion/blogs" class="categories-nav_link ">Guest Blogs</a>
</li>
<li>
<a href="/kenya/blogs-opinion/letters" class="categories-nav_link ">Letters to the Editor</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cutting-edge" class="categories-nav_link ">Cutting Edge</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cartoons" class="categories-nav_link ">Cartoons</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/sports" class="categories-nav_link categories-nav_title">
Sports
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/sports/football" class="categories-nav_link ">Football</a>
</li>
<li>
<a href="/kenya/sports/athletics" class="categories-nav_link ">Athletics</a>
</li>
<li>
<a href="/kenya/sports/rugby" class="categories-nav_link ">Rugby</a>
</li>
<li>
<a href="/kenya/sports/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/sports/talkup" class="categories-nav_link ">TalkUP!</a>
</li>
<li>
<a href="/kenya/sports/other-sports" class="categories-nav_link ">Other Sports</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/life-and-style" class="categories-nav_link categories-nav_title">
Life &amp; Style
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/life-and-style/culture" class="categories-nav_link ">Culture</a>
</li>
<li>
<a href="/kenya/life-and-style/family" class="categories-nav_link ">Family</a>
</li>
<li>
<a href="/kenya/life-and-style/relationships" class="categories-nav_link ">Relationships</a>
</li>
<li>
<a href="/kenya/life-and-style/art-books" class="categories-nav_link ">Art &amp; Books</a>
</li>
<li>
<a href="/kenya/life-and-style/travel" class="categories-nav_link ">Travel</a>
</li>
<li>
<a href="/kenya/life-and-style/wellness" class="categories-nav_link ">Wellness</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/newsletters" class="categories-nav_link categories-nav_title">
Newsletters
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/audio" class="categories-nav_link categories-nav_title">
Audio
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/puzzles" class="categories-nav_link categories-nav_title">
Puzzles
</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-label="Site Information Navigation" class="page-footer_metanav col-1-2 medium-col-2-3">
<ul class="clearfix">
<li><a href="/kenya/empower" target="_blank">Empower Africa</a></li>
<li><a href="/kenya/contact-us-294088" target="_blank">Contact Us</a></li>
<li><a href="/kenya/frequently-asked-questions-303716" target="_blank">Frequently asked questions</a></li>
<li><a href="/kenya/nmg-privacy-policy-303724" target="_blank">NMG Privacy Policy</a></li>
<li><a href="/kenya/terms-and-conditions" target="_blank">Terms and Conditions of Use</a></li>
<li><a href="/kenya/our-blog-rules-549010" target="_blank">Our Blog Rules</a></li>
</ul>
</nav>
<p class="page-footer_copyright col-1-1 medium-col-1-3">
<span class="page-footer_copyright-year">Nation Media Group &copy; 2021</span> Nation Part of <a href="https://www.nationmedia.com/" rel="noreferrer">Nation Media Group</a>
</p>
</div>
<figure class="page-footer_decoration">
<img data-src="/resource/crblob/1337610/4ffe0a0e8c1ddb5abcac8c8d4862e60e/footer-decoration-svg-data.svg" alt="Decoration" width="100" height="100" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</footer></section>
<div class="evolok-widgets">
<ev-paywall group-name="default" redirect=false></ev-paywall>
<ev-paywall-notifier></ev-paywall-notifier>
<div style="visibility: hidden; height: 0px; overflow: hidden; position: absolute;">
<ev-login ev-modal id="login-widget" title="Login" auth-scheme-name="default" service-name="login" show-labels="false" show-social="true" social-networks="['facebook', 'google']" auto-register="false" auto-populate="false" forgot-password-service="reset-password"></ev-login>
<ev-registration ev-modal id="registration-widget" title="Sign up for free" auth-scheme-name="default" service-name="registration" show-labels="false" show-social="true" social-networks="['facebook', 'google']" auto-login="true" auto-register="false" auto-populate="true"></ev-registration>
<ev-social-registration id="socialRegistration" ev-modal title="Almost there!" description="Would you like to receive marketing updates and offers from Nation? You may opt out anytime." auth-scheme-name="default" service-name="default" auto-register="false" auto-populate="true"></ev-social-registration>
<div id="registration-welcome" ev-modal>
<div class="registration-welcome">
<div class="ev-widget-header">
<p>Welcome!</p>
</div>
<div class="ev-widget-body">
<div class="ev-text-wrapper">
<div class="ev-title-wrapper">
<h3>You're all set to enjoy unlimited Prime content.</h3>
</div>
</div>
<div class="ev-button-wrapper">
<div>
<button class="btn">
Start reading
</button>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<script>
var evolokParams = {
articleId: '3477006',
section: 'News',
category: 'Diaspora',
authors: 'Hilary Kimuyu',
site: 'Nation',
tags: 'Investigations',
contentType: 'article',
publishDate: '2021-07-18T04:00:00Z',
premium: false
};
var evolokInitParams = {
url: 'https://nmg.evolok.net',
enableSSOMode: false,
enableSeamlessMode: false,
cookieDomain: 'nation.africa',
socialLoginRedirectUri: 'https://nation.africa/kenya/account',
homepageUrl: '/kenya',
termsAndConditionsUrl: '/kenya/terms-and-conditions',
faqUrl: '/kenya/frequently-asked-questions-303716',
}
</script>
<script>
window.polyfillsForOldBrowsersLoaded = false;
if ("Promise" in window &&
!!window.HTMLPictureElement &&
'objectFit' in document.documentElement.style) {
window.polyfillsForOldBrowsersLoaded = true;
} else {
var f = document.getElementsByTagName('script')[0];
var j = document.createElement('script');
j.async = true;
j.src = "/resource/themes/nation-2020/js/polyfills-for-old-browsers.ts-491110-46.js";
f.parentNode.insertBefore(j,f);
}
</script>
<script data-evolok-script="true" defer data-src="https://scripts.nation.africa/ev-widgets.min-UAT-v16062021.js"></script>
<link rel="stylesheet" href="https://scripts.nation.africa/css/ev-widgets.min.css">
<script defer src="/resource/themes/nation-2020/js/nation-2020.ts-491108-122.js"></script>
<script id="doubleClickJS" async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<!--[if IE 9]> <script>
var dcScript = document.getElementById("doubleClickJS");
dcScript.parentNode.removeChild(dcScript);
</script> <![endif]-->
<script type="text/javascript">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</script><script type='text/javascript'>
var isVideoPage = false;
var trackVideo = isVideoPage || window.hasEmbeddedVideo === true;
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'nation.africa';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'News,News - Diaspora';
_sf_async_config.authors ='Hilary Kimuyu';
/** CONFIGURATION END **/
function loadChartbeat() {
var chartbeatScript = document.createElement('script');
chartbeatScript.type = 'text/javascript';
chartbeatScript.async = true;
chartbeatScript.src = '//static.chartbeat.com/js/chartbeat.js';
var n = document.getElementsByTagName('script')[0];
n.parentNode.insertBefore(chartbeatScript, n);
}
function loadChartbeatWithVideoTracking() {
// YouTube's API script, required for Chartbeat's video engagement tracking -->
var youtubeScript = document.createElement('script');
youtubeScript.type = 'text/javascript';
youtubeScript.async = true;
youtubeScript.src = '//www.youtube.com/iframe_api';
// Chartbeat Video script
var chartbeatVideoScript = document.createElement('script');
chartbeatVideoScript.type = 'text/javascript';
chartbeatVideoScript.async = true;
chartbeatVideoScript.src = '//static.chartbeat.com/js/chartbeat_video.js';
// Include both scripts
var n = document.getElementsByTagName('script')[0];
n.parentNode.insertBefore(youtubeScript, n);
n.parentNode.insertBefore(chartbeatVideoScript, n);
}
if (trackVideo) {
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeatWithVideoTracking();
} else {
loadChartbeat();
}
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script type="text/javascript">
_atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.africa",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>
<script type="text/javascript">
function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(disableAdFeaturesPlugin, contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function setupGa(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
}
function setGaCustomDimension(name, content, trackerName) {
var t = _gaTrackerPrefix(trackerName);
ga(t.concat('set'), name, content);
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-1030601-83", "nation.africa");
var gaPageData = new GaPageviewData(
false,
"3477006",
"CMArticle",
"31772_516_636_2982",
"/kenya/news/diaspora/diaspora-news/kenyan-obadiah-kinara-in-us-secret-burial-of-dorothy-ongera-lawsuit-arrested-3477006"
,"Hilary Kimuyu",
"18-07-2021",
"Investigations"
);
setupGa(ga, gaAccountData, gaPageData);
function sendGaTrackPageview() {
gaTrackPageview(ga, gaAccountData, gaPageData);
}
</script>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'670a4ad51e880641',m:'1be03a7248c5892a72214eef22696e42d2b3be83-1626596442-1800-AbFu52gQQ5SlKnTANCAV/aDEelqOXakxasiq4z8+zGty+a8B9QWwEftP+AxEim6QgTjXGsNHn3BTW0xkI3OBmQKxw/e8DZXygMhI9yqv5oDZSPeiB3U2I7qf6an4/1OaoWaVIZFmr5ALux3GvJuDr972WlJHd96DSpUna/dMtCUE+IE1zoxYG/QMVaMjl5Htk5tF0/wBy1o9sZGCwfqtM12c61Y58FFsbggJ3l0dMtkV6Wvsix6nMZ+aTohBggxCMqKLAwOPi99mpucX1dP2BwY=',s:[0x47d133eae8,0x2f124b1026],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"670a4ad51e880641","token":"0da52c244fc64e7c8de980e5d83e0a85","version":"2021.6.0","si":10}'></script>
</body></html>
