<!DOCTYPE html>
<!--[if IE 9]><html lang="en" class="ie9"><![endif]-->
<html lang="en" dir="ltr">
<head>
<script src="/cdn-cgi/apps/head/SZ6jLMc1rEwDmfiixD4-QRoOmS4.js"></script><script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-PGPJTQ2');</script>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<title>How Naivasha detectives rescued baby Liam from kidnapper | Nation</title>
<meta name="description" content="
Abductor was lured into the police trap after he was told the baby had fallen ill.">
<script type="application/ld+json">
{
"@context": "https://schema.org",
"@type": "NewsArticle",
"mainEntityOfPage": {
"@type": "WebPage",
"@id": "https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596"
},
"headline": "How Naivasha detectives rescued baby Liam",
"image": [
"https://nation.africa/resource/image/3430788/landscape_ratio16x9/1600/900/da7e4637a71e5320861c6ef90acdf8ee/QK/baby-liam-pic.jpg",
"https://nation.africa/resource/image/3430788/landscape_ratio3x2/1620/1080/bf0a65a1b8683713a2160d070c75dbf4/LM/baby-liam-pic.jpg",
"https://nation.africa/resource/image/3430788/portrait_ratio1x1/1600/1600/38fa1eb4429ed9125da3369baa90c6d7/Is/baby-liam-pic.jpg"
],
"datePublished": "2021-06-09T06:00:00Z",
"dateModified": "2021-06-09T06:17:13Z",
"author": {
"@type": "Person",
"name": [
"Macharia Mwangi"
]
},
"publisher": {
"@type": "Organization",
"name": "Nation",
"logo": {
"@type": "ImageObject",
"url": "https://nation.africa/resource/crblob/1909958/2d96fc16039969eac48a6e8f3e055af2/structured-data-logo-png-data.png"
}
},
"description": "
Abductor was lured into the police trap after he was told the baby had fallen ill....",
"isAccessibleForFree": "False",
"hasPart":
{
"@type": "WebPageElement",
"isAccessibleForFree": "False",
"cssSelector" : ".text-block"
}
}
</script>
<script type="application/ld+json">
{
"@context": "http://schema.org",
"@type": "BreadcrumbList",
"itemListElement": [
{
"@type": "ListItem",
"position": 1,
"name": "Nation",
"item": "https://nation.africa/kenya"
}
,
{
"@type": "ListItem",
"position": 2,
"name": "Counties",
"item": "https://nation.africa/kenya/counties"
}
,
{
"@type": "ListItem",
"position": 3,
"name": "Nakuru",
"item": "https://nation.africa/kenya/counties/nakuru"
}
]
}
</script>
<meta property="og:site_name" content="Nation" />
<meta property="og:type" content="article" />
<meta property="og:article:published_time" content="2021-06-09T06:17:13Z" />
<meta property="og:title" content="How Naivasha detectives rescued baby Liam from kidnapper" />
<meta property="og:description" content="
Abductor was lured into the police trap after he was told the baby had fallen ill.">
<meta property="og:url" content="https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596" />
<meta property="og:locale" content="en" />
<meta property="og:locale:alternate" content="en_US" />
<meta property="og:image" content="https://nation.africa/resource/image/3430788/landscape_ratio3x2/1200/800/bf0a65a1b8683713a2160d070c75dbf4/vl/baby-liam-pic.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="800" />
<meta property="fb:app_id" content="174023979648743" />
<meta name="twitter:site" content="@dailynation">
<meta name="twitter:card" content="summary_large_image"> <link rel="canonical" href="https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596">
<meta name="keywords" content="Baby Liam,Kidnap,naivasha, DCI, Thika">
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#303030">
<meta name="msapplication-TileColor" content="#ffc40d">
<meta name="theme-color" content="#ffffff">
<meta name="google-site-verification" content="7PI23eF83yLrptihU4-C11bEaznAQl8mts5BfCS1W2U" />
<link rel="dns-prefetch" href="https://nmg.evolok.net" />
<link rel="preconnect" href="https://nmg.evolok.net" />
<link rel="dns-prefetch" href="https://scripts.nation.africa" />
<link rel="preconnect" href="https://scripts.nation.africa" />
<link rel="preload" href="https://securepubads.g.doubleclick.net/tag/js/gpt.js" as="script">
<link rel="preload" href="/resource/crblob/491076/8f26773838fb46720f8eee321565ae9c/morion-regular-woff2-data.woff2" as="font" type="font/woff2" crossorigin>
<link rel="preload" href="/resource/crblob/491082/db592c09b66baa562172b62cac699422/morion-semibold-woff2-data.woff2" as="font" type="font/woff2" crossorigin>
<style>
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 400;
font-display: fallback;
src: local('Roboto'), local('Roboto-Regular'),
url(/resource/crblob/491098/314b3e27a8fc4d780a703b8c6d60eb2e/roboto-regular-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491096/396f61f2524c1a087da7fe4cf6554302/roboto-regular-woff-data.woff) format('woff'),
url(/resource/crblob/491094/84a6341fddcb66cd50fbd315345d9a79/roboto-regular-ttf-data.ttf) format('ttf');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 500;
font-display: fallback;
src: local('Roboto Medium'), local('Roboto-Medium'),
url(/resource/crblob/491092/dcc5e5d97b52622a8acca0d909ab2e27/roboto-medium-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491090/1e49e636e65523052023a5500a51d168/roboto-medium-woff-data.woff) format('woff'),
url(/resource/crblob/491088/b5f1f1704739a86b2300b6e6258ec7ff/roboto-medium-ttf-data.ttf) format('ttf');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: normal;
font-weight: 700;
font-display: fallback;
src: local('Roboto Bold'), local('Roboto-Bold'),
url(/resource/crblob/1909918/e5f93140b1b696f3b64ab1e978eb8a92/roboto-bold-woff2-data.woff2) format('woff2'),
url(/resource/crblob/1909916/3eba6b17da134b2434afb8ad6d2c83a4/roboto-bold-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: italic;
font-weight: 400;
font-display: fallback;
src: local('Roboto Italic'), local('Roboto-Italic'),
url(/resource/crblob/491086/c20ba07e455c114af36596dbe6c7eb51/roboto-italic-woff2-data.woff2) format('woff2'),
url(/resource/crblob/491084/5b17397b930cee50ab6c47fd10641c6f/roboto-italic-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Roboto";
font-style: italic;
font-weight: 700;
font-display: fallback;
src: local('Roboto Bold Italic'), local('Roboto-BoldItalic'),
url(/resource/crblob/1909922/f13d361ffda533c07c9a3df7c140c61c/roboto-bolditalic-woff2-data.woff2) format('woff2'),
url(/resource/crblob/1909920/f7308fd720d9f134b6c3b749b90d2edf/roboto-bolditalic-woff-data.woff) format('woff');
unicode-range: U+0000-00FF, U+0131, U+0152-0153, U+02BB-02BC, U+02C6, U+02DA, U+02DC, U+2000-206F, U+2074, U+20AC, U+2122, U+2191, U+2193, U+2212, U+2215, U+FEFF, U+FFFD;
}
@font-face {
font-family: "Morion";
font-style: normal;
font-weight: 300;
font-display: fallback;
src: url(/resource/crblob/1905440/d98f82389286b2e51bb541e2e1094c8e/morion-light-woff2-data.woff2) format("woff2"),
url(/resource/crblob/1905438/9e36b3c52b6e9ce720c63718506804ff/morion-light-woff-data.woff) format("woff");
}
@font-face {
font-family: "Morion";
font-style: normal;
font-weight: 400;
font-display: fallback;
src: url(/resource/crblob/491076/8f26773838fb46720f8eee321565ae9c/morion-regular-woff2-data.woff2) format("woff2"),
url(/resource/crblob/491074/d3d0f9d8049e5cd34b83418007cfd551/morion-regular-woff-data.woff) format("woff"),
url(/resource/crblob/491072/f527ba223329157953b58091c798640e/morion-regular-ttf-data.ttf) format("truetype");
}
@font-face {
font-family: "Morion";
font-weight: 600;
font-display: fallback;
src: url(/resource/crblob/491082/db592c09b66baa562172b62cac699422/morion-semibold-woff2-data.woff2) format("woff2"),
url(/resource/crblob/491080/4b3380c8a84bfbc97119f89918051b90/morion-semibold-woff-data.woff) format("woff"),
url(/resource/crblob/491078/19f56eb45799e6468b58e3207185344a/morion-semibold-ttf-data.ttf) format("truetype");
}
@font-face {
font-family: "Morion";
font-weight: 600;
font-style: italic;
font-display: fallback;
src: url(/resource/crblob/1337618/950d6833f150399efafa7f7783d2176a/morion-semibolditalic-woff2-data.woff2) format("woff2"),
url(/resource/crblob/1337616/3394fd8e0b9b830296cf395bddc1586d/morion-semibolditalic-woff-data.woff) format("woff"),
url(/resource/crblob/1337614/8fc6226dcb8da45c46665b68afc4bcd1/morion-semibolditalic-ttf-data.ttf) format("truetype");
}
</style>
<link href="/resource/themes/nation-2020/css/nation-2020-491114-101.css" rel="stylesheet">
<link rel="stylesheet" href="/resource/themes/nation-2020/css/ev-widgets.min-653026-2.css" media="print" onload="this.media='all'">
<style>
.color-set-color-1 {
background: #B9002D;
color: #FFFFFF;
}
.color-set-color-2 {
background: #E00026;
color: #FFFFFF;
}
.color-set-color-3 {
background: #FF415D;
color: #000000;
}
.color-set-color-4 {
background: #FF415D;
color: #000000;
}
.color-set-color-5 {
background: #FF001B;
color: #000000;
}
.color-set-color-6 {
background: #FFC3CA;
color: #000000;
}
.color-set-color-7 {
background: #F0F0F0;
color: #000000;
}
.color-set-color-8 {
background: #F8F8F8;
color: #000000;
}
.color-set-color-9 {
background: #FFC3CA;
color: #000000;
}
.color-set-color-10 {
background: #FFC3CA;
color: #000000;
}
/* Styling exceptions for Evolok widgets. Needed because we have no control over their HTML so we can't rely on adding classes like elsewhere. */
/* Paywall button */
.ev-modals .ev-open-modal-paywall-REQUIRE_ENTITLEMENT .ev-button-wrapper .btn,
.ev-modals .ev-open-modal-paywall-REQUIRE_LOGIN_WITH_ENTITLEMENT .ev-button-wrapper .btn {
background-color: #E00026;
color: #FFFFFF;
}
</style>
<script>
var icons = new XMLHttpRequest();
icons.open("GET", "/resource/crblob/499920/04a4c0f8df2bad832b0e93512ac0ae2b/icons-svg-data.svg");
icons.send();
icons.onload = function () {
var d = document.createElement("div");
d.innerHTML = icons.responseText;
d.style = "display: none";
document.body.insertBefore(d, document.body.childNodes[0]);
}
</script>
<script>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</script>
<script>
window.googletag = window.googletag || {cmd: []};
window.windowInnerWidth = window.innerWidth;
window.adDesktopBreakPoint = 1000;
window.adSlots = {};
function shouldRenderAd(isMobileAd) {
return (window.windowInnerWidth <= window.adDesktopBreakPoint && isMobileAd) ||
(window.windowInnerWidth > window.adDesktopBreakPoint && !isMobileAd);
}
googletag.cmd.push(function() {
window.bk_dfp_integration = window.bk_dfp_integration || {};
window.bk_dfp_integration.functions = window.bk_dfp_integration.functions || {};
if (typeof bk_dfp_integration.functions.sendDfp === "function") {
bk_dfp_integration.functions.sendDfp();
}
googletag.pubads().setTargeting('url', window.location.pathname.split( '/' )[1]);
if (window.location.pathname.split( '/' )[2]) {
googletag.pubads().setTargeting('url1', window.location.pathname.split( '/' )[2]);
}
if (window.location.pathname.split( '/' )[3]) {
googletag.pubads().setTargeting('url2', window.location.pathname.split( '/' )[3]);
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-1'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-1", [[320,50], [320,100], [300, 250]], "mobile-article-ad-1")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-1'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-1", [[728,90], [970,90], [300, 250]], "desktop-article-ad-1")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-2'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-2", [[320,50], [320,100], [300, 250]], "mobile-article-ad-2")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-2'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-2", [[728,90], [970,90], [300, 250]], "desktop-article-ad-2")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-ad-3'] = googletag
.defineSlot("/1010816/Z-DN-728x90-Article-3", [[728,90], [970,90], [300, 250]], "desktop-article-ad-3")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-3'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-300x250-article-3", [[320,50], [320,100], [300, 250]], "mobile-article-ad-3")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth > window.adDesktopBreakPoint) {
window.adSlots['desktop-article-above-navigation'] = googletag
.defineSlot("/1010816/Z-DN-728x90-ArticleTop", [[728,90], [970,90]], "desktop-article-above-navigation")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
if (windowInnerWidth <= window.adDesktopBreakPoint) {
window.adSlots['mobile-article-ad-top'] = googletag
.defineSlot("/1010816/Z-DN-Mobile-Article-Strip", [[320,50], [320,100]], "mobile-article-ad-top")
.setCollapseEmptyDiv(true, true)
.addService(googletag.pubads());
}
googletag
.defineOutOfPageSlot('/1010816/Z-DN-RoadBlock','div-gpt-ad-1600501942202-0')
.addService(googletag.pubads());
googletag.enableServices();
});
</script> <script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({article:'auto'});
!function (e, f, u, i) {
if (!document.getElementById(i)){
e.async = 1;
e.src = u;
e.id = i;
f.parentNode.insertBefore(e, f);
}
}(document.createElement('script'),
document.getElementsByTagName('script')[0],
'//cdn.taboola.com/libtrc/nationmediagroup-dailynation/loader.js',
'tb_loader_script');
if(window.performance && typeof window.performance.mark == 'function')
{window.performance.mark('tbl_ic');}
</script>
<script async src="https://securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head><body>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PGPJTQ2"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<div id='div-gpt-ad-1600501942202-0' style="position: absolute; top: 0;">
<script type="text/javascript">
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1600501942202-0'); });
</script>
</div>
<section class="page-content detail-content">
<header class="page-grid-header">
<header data-page-header="true" class="page-header">
<div class="page-header_ad color-set-color-1" data-page-header-ad="true">
<div class="ad-leaderboard_wrap">
<div id="desktop-article-above-navigation" class="ad-leaderboard">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-above-navigation");
});
}
</script>
</div>
</div>
</div>
<nav class="main-nav color-set-color-1" data-main-nav="true">
<div class="grid-container">
<div class="main-nav_buttons">
<button class="main-nav_menu-btn" data="open-menu" aria-haspopup="true" aria-controls="menu" aria-expanded="false" aria-label="Toggle menu">
<svg class="icon-menu-button" aria-hidden="true" focusable="false">
<use xlink:href="#icon-menu-button"></use>
</svg>
<svg class="icon-close" aria-hidden="true" focusable="false">
<use xlink:href="#icon-close"></use>
</svg>
<span class="main-nav_btn-close-text">Close</span>
<span class="main-nav_btn-menu-text">Menu</span>
</button>
<a href="/kenya/search" class="main-nav_search-button" aria-label="Search page">
<svg class="icon-search" aria-hidden="true" focusable="false">
<use xlink:href="#icon-search"></use>
</svg>
<span>Search</span>
</a>
</div>
<h2 class="logo">
<a href="/kenya" aria-label="Homepage">
<svg class="logo-svg" xmlns="http://www.w3.org/2000/svg" fill="currentColor" viewBox="0 0 146 30">
<path fill-rule="evenodd" d="M108.648553,27.0221865 C103.845659,28.8163987 97.9344051,24.8691318 95.4446945,18.2054662 C92.9550804,11.540836 94.8282958,4.68424437 99.6302251,2.89003215 C104.432154,1.09572347 110.344373,5.04308682 112.83418,11.7066559 C115.323794,18.3713826 113.449518,25.2279743 108.648553,27.0221865 M104.138907,0 C112.130868,0 118.609325,6.69646302 118.609325,14.9565916 C118.609325,23.2157556 112.130868,29.9122186 104.138907,29.9122186 C96.14791,29.9122186 89.6694534,23.2157556 89.6694534,14.9565916 C89.6694534,6.69646302 96.14791,0 104.138907,0 Z M126.807698,0.490987138 L143.688727,21.2444277 L143.697987,0.507578778 L145.859145,0.507578778 L145.859145,29.438865 L142.724096,29.438865 L125.843068,8.68436334 L125.843164,29.4464855 L123.67265,29.438865 L123.67265,0.490987138 L126.807698,0.490987138 Z M7.09228296,0.478446945 L22.1453376,19.060119 L22.1453376,3.33095498 L20.2160772,0.973302251 L20.2160772,0.490987138 L26.2450161,0.490987138 L26.2450161,0.973302251 L24.3157556,3.33095498 L24.3157556,29.4298939 L22.8688103,29.4298939 L4.34974277,6.53053698 L4.29967846,6.46301286 L4.29967846,26.5900225 L6.22893891,28.9475788 L6.22893891,29.4298939 L0.2,29.4298939 L0.2,28.9475788 L2.12926045,26.5900225 L2.12926045,3.55667846 L0.2,0.973302251 L0.2,0.490987138 L7.09228296,0.478446945 Z M76.4057878,0.477491961 L76.4057878,5.55530547 L66.2771704,5.55530547 L66.2771704,26.5900322 L68.2064309,28.9475884 L68.2064309,29.4299035 L62.177492,29.4299035 L62.177492,28.9475884 L64.1067524,26.5900322 L64.1067524,5.55530547 L53.978135,5.55530547 L53.978135,0.477491961 L76.4057878,0.477491961 Z M43.1260064,0.475562701 L53.9780965,29.4299035 L48.1903151,29.4299035 L45.2068103,21.4717042 L34.0362958,21.4717042 L31.0681286,29.4299035 L31.0681286,29.4212219 L28.6565531,29.4212219 L38.4118585,3.34533762 L39.4836592,0.479421222 L41.8681286,0.477491961 L43.1260064,0.475562701 Z M84.3638907,0.490996785 L84.3639871,29.4221865 L82.1935691,29.4221865 L82.1935691,0.490996785 L84.3638907,0.490996785 Z M39.6080965,6.53633441 L34.9362958,19.0601286 L44.3029518,19.0601286 L39.6080965,6.53633441 Z" />
</svg>
</a>
</h2>
<div class="main-nav_account">
<div class="account-menu" data="account-menu">
<button type="button" class="account-menu_login-btn" data="log-in">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="not-loggedIn">
<span class="profile-btn">
<span class="profile-btn_name">Log in</span>
<span class="profile-btn_icon color-set-color-3">
<svg class="icon-user" aria-hidden="true" focusable="false">
<use xlink:href="#icon-user"></use>
</svg>
</span>
</span>
</ev-profile-when>
</ev-profile>
</button>
<button class="account-menu_button" data="toggle-account-menu" aria-haspopup="true" aria-controls="account-menu" aria-expanded="false" aria-label="Open account menu">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="available">
<span class="profile-btn">
<span class="profile-btn_name">
{{profile.name ? profile.name : profile.email.substr(0,profile.email.indexOf("@"))}}
</span>
<span class="profile-btn_icon color-set-color-3">
<svg class="icon-user" aria-hidden="true" focusable="false">
<use xlink:href="#icon-user"></use>
</svg>
</span>
</span>
</ev-profile-when>
<ev-profile-when state="not-loggedIn">
<span class="default-btn color-set-color-3">
Subscribe
</span>
</ev-profile-when>
</ev-profile>
</button>
<nav id="account-menu" class="account-menu_popup">
<svg xmlns="http://www.w3.org/2000/svg" width="30" height="15" viewBox="0 0 30 15" class="account-menu_popup-triangle">
<path fill="#F8F8F8" fill-rule="evenodd" d="M1327,49 C1327,59 1332,64 1342,64 L1312,64 C1322,64 1327,59 1327,49 Z" transform="translate(-1312 -49)" />
</svg>
<div class="account-menu_popup-inner">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="available">
<a href="/kenya/account" class="account-menu_popup-header">My account</a>
<ul>
<li>
<a href="/kenya/account#details" class="account-menu_popup-link">Personal details</a>
</li>
<li>
<a href="/kenya/account#password" class="account-menu_popup-link">Change password</a>
</li>
<li>
<a href="/kenya/account#purchases" class="account-menu_popup-link">Purchases</a>
</li>
<li>
<button class="account-menu_popup-link" data="sign-out">Sign out</button>
</li>
</ul>
</ev-profile-when>
<ev-profile-when state="not-loggedIn">
<div class="account-menu_signin-register">
<p class="account-menu_signin-text">Already signed up? <button type="button" data="log-in-popup">Log in</button></p>
<button type="button" data="register" class="default-btn default-btn-no-color">Sign up</button>
</div>
</ev-profile-when>
</ev-profile>
</div>
</nav>
</div> </div>
</div>
</nav>
<nav class="sub-nav color-set-color-2" data-sub-nav="true">
<div class="grid-container">
<h3 class="sub-nav_section-title" data-sub-nav-header="true">
<a href="/kenya/counties">
<span class="sub-nav_section-title-desktop">Counties</span>
<span class="sub-nav_section-title-mobile">
Nakuru
</span>
</a>
</h3>
<ul class="sub-nav_link-list" data-sub-nav-items="true">
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/nairobi-metro">Nairobi Metro</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/coast">Coast</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/mountain">Mountain</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/lake-region">Lake Region</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/rift-valley">Rift Valley</a>
</li>
<li class="sub-nav_link-list-item invisible">
<a href="/kenya/counties/northern">Northern</a>
</li>
<li class="sub-nav_link-list-item invisible">
<button data="open-menu" aria-haspopup="true" aria-controls="menu" aria-expanded="false">
<svg class="icon-more-link" aria-hidden="true" focusable="false">
<use xlink:href="#icon-more-link"></use>
</svg>
<span>More</span>
</button>
</li>
</ul>
</div>
</nav>
<nav class="mega-menu" data-mega-menu="true" id="menu">
<section class="mega-menu_section clearfix color-set-color-8">
<div class="grid-container">
<div class="col-1-1">
<div class="mega-menu_search">
<a href="/kenya/search" class="mega-menu_search-button" aria-label="Search page">
<svg class="icon-search" aria-hidden="true" focusable="false">
<use xlink:href="#icon-search"></use>
</svg>
<span>Search</span>
</a>
</div>
</div>
<nav role="navigation" aria-label="Site index" class="categories-nav col-1-1">
<ul class="nested-cols categories-nav_categories">
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/news" class="categories-nav_link categories-nav_title">
News
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/news/national" class="categories-nav_link ">National</a>
</li>
<li>
<a href="/kenya/news/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/news/world" class="categories-nav_link ">World</a>
</li>
<li>
<a href="/kenya/news/gender" class="categories-nav_link ">Gender</a>
</li>
<li>
<a href="/kenya/news/health" class="categories-nav_link ">Health</a>
</li>
<li>
<a href="/kenya/news/tech" class="categories-nav_link ">Tech</a>
</li>
<li>
<a href="/kenya/news/newsplex" class="categories-nav_link ">Newsplex</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category current-section">
<a href="/kenya/counties" class="categories-nav_link categories-nav_title">
Counties
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/counties/nairobi-metro" class="categories-nav_link current-section">Nairobi Metro</a>
</li>
<li>
<a href="/kenya/counties/coast" class="categories-nav_link current-section">Coast</a>
</li>
<li>
<a href="/kenya/counties/mountain" class="categories-nav_link current-section">Mountain</a>
</li>
<li>
<a href="/kenya/counties/lake-region" class="categories-nav_link current-section">Lake Region</a>
</li>
<li>
<a href="/kenya/counties/rift-valley" class="categories-nav_link current-section">Rift Valley</a>
</li>
<li>
<a href="/kenya/counties/northern" class="categories-nav_link current-section">Northern</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/business" class="categories-nav_link categories-nav_title">
Business
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/business/companies" class="categories-nav_link ">Companies</a>
</li>
<li>
<a href="/kenya/business/finance-and-markets" class="categories-nav_link ">Finance and Markets</a>
</li>
<li>
<a href="/kenya/business/seeds-of-gold" class="categories-nav_link ">Seeds of Gold</a>
</li>
<li>
<a href="/kenya/business/enterprise" class="categories-nav_link ">Enterprise</a>
</li>
<li>
<a href="/kenya/business/shillings-sense" class="categories-nav_link ">Shillings &amp; Sense</a>
</li>
<li>
<a href="/kenya/business/leadership" class="categories-nav_link ">Leadership</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/blogs-opinion" class="categories-nav_link categories-nav_title">
Opinion
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/blogs-opinion/editorials" class="categories-nav_link ">Editorials</a>
</li>
<li>
<a href="/kenya/blogs-opinion/opinion" class="categories-nav_link ">Our Columnists</a>
</li>
<li>
<a href="/kenya/blogs-opinion/blogs" class="categories-nav_link ">Guest Blogs</a>
</li>
<li>
<a href="/kenya/blogs-opinion/letters" class="categories-nav_link ">Letters to the Editor</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cutting-edge" class="categories-nav_link ">Cutting Edge</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cartoons" class="categories-nav_link ">Cartoons</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/sports" class="categories-nav_link categories-nav_title">
Sports
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/sports/football" class="categories-nav_link ">Football</a>
</li>
<li>
<a href="/kenya/sports/athletics" class="categories-nav_link ">Athletics</a>
</li>
<li>
<a href="/kenya/sports/rugby" class="categories-nav_link ">Rugby</a>
</li>
<li>
<a href="/kenya/sports/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/sports/talkup" class="categories-nav_link ">TalkUP!</a>
</li>
<li>
<a href="/kenya/sports/other-sports" class="categories-nav_link ">Other Sports</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/life-and-style" class="categories-nav_link categories-nav_title">
Life &amp; Style
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/life-and-style/culture" class="categories-nav_link ">Culture</a>
</li>
<li>
<a href="/kenya/life-and-style/family" class="categories-nav_link ">Family</a>
</li>
<li>
<a href="/kenya/life-and-style/relationships" class="categories-nav_link ">Relationships</a>
</li>
<li>
<a href="/kenya/life-and-style/art-books" class="categories-nav_link ">Art &amp; Books</a>
</li>
<li>
<a href="/kenya/life-and-style/travel" class="categories-nav_link ">Travel</a>
</li>
<li>
<a href="/kenya/life-and-style/wellness" class="categories-nav_link ">Wellness</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/newsletters" class="categories-nav_link categories-nav_title">
Newsletters
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/audio" class="categories-nav_link categories-nav_title">
Audio
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/puzzles" class="categories-nav_link categories-nav_title">
Puzzles
</a>
</li>
</ul>
</nav> </div>
<nav class="channels-nav">
<ul class="grid-container">
<li class="col-1-1 medium-col-1-3">
<h2 class="channels-nav_heading">Nation ePaper</h2>
<ul>
<li class="channels-nav_link-item">
<a href="https://newsstand.nationmedia.com/" target="_blank" rel="noopener">Nation</a>
</li>
</ul>
</li>
</ul>
</nav> </section>
</nav>
<div class="breaking-news">
<div class="container">
<div class="breaking-news-container" data-separator="" data-fragments-link="/ajax/breaking-news/kenya">
</div>
</div>
</div></header> </header>
<div class="article-page" data-article-content>
<header class="article-special-header color-set-color-6">
<div class="article-special-header_picture">
<figure class="object-fit-container img-space_portrait_ratio1x1">
<img src="/resource/image/3430788/portrait_ratio1x1/320/180/38fa1eb4429ed9125da3369baa90c6d7/FJ/baby-liam-pic.jpg" srcset="
/resource/image/3430788/portrait_ratio1x1/320/320/38fa1eb4429ed9125da3369baa90c6d7/Nm/baby-liam-pic.jpg 320w,
/resource/image/3430788/portrait_ratio1x1/640/640/38fa1eb4429ed9125da3369baa90c6d7/en/baby-liam-pic.jpg 640w,
/resource/image/3430788/portrait_ratio1x1/720/720/38fa1eb4429ed9125da3369baa90c6d7/fC/baby-liam-pic.jpg 720w,
/resource/image/3430788/portrait_ratio1x1/960/960/38fa1eb4429ed9125da3369baa90c6d7/Xo/baby-liam-pic.jpg 960w,
/resource/image/3430788/portrait_ratio1x1/1280/1280/38fa1eb4429ed9125da3369baa90c6d7/yI/baby-liam-pic.jpg 1280w,
/resource/image/3430788/portrait_ratio1x1/1600/1600/38fa1eb4429ed9125da3369baa90c6d7/Is/baby-liam-pic.jpg 1600w
" sizes="(min-width: 1240px) 50vw, 100vw" alt="Baby Liam rescued" />
</figure>
</div>
<div class="article-special-header_caption grid-container">
<div class="article-picture_caption col-1-1">
Courtesy
</div>
</div>
<div class="article-special-header_title">
<div class="grid-container-small">
<div class="col-1-1 article-special-header_title-wrapper">
<div class="article-special-header_labels">
<h2 class="section-label" style="background: #FF415D; color:#000000;">
<a href="/kenya/counties/nakuru">Nakuru</a>
</h2>
<p class="section-label prime-section-label">
Prime
</p>
</div>
<h1 class="title-large">How Naivasha detectives rescued baby Liam from kidnapper</h1>
<time class="date" datetime="2021-06-09T06:00:00Z">
Wednesday, June 09, 2021
</time>
</div>
</div>
</div>
</header>
<div class="article-content xxx">
<div class="grid-container-small">
<div class="col-1-1">
<div class="article-authors">
<div class="article-authors_inner clearfix">
<div class="article-authors_imgs clearfix">
<figure class="article-authors_img lazy-img-container" style="z-index: 1;">
<a href="/kenya/macharia-mwangi-3664">
<img data-src="/resource/image/3666/portrait_ratio1x1/60/60/815b1a8e17d6ca280285f8f660ba8e79/xD/mwangi.jpg" data-srcset="
/resource/image/3666/portrait_ratio1x1/60/60/815b1a8e17d6ca280285f8f660ba8e79/xD/mwangi.jpg 60w,
/resource/image/3666/portrait_ratio1x1/120/120/815b1a8e17d6ca280285f8f660ba8e79/Oc/mwangi.jpg 120w
" sizes="60px" alt="" class="lazy-img" data-lazy-img="true" loading="lazy" />
</a>
</figure>
</div>
<div class="article-authors_texts">
<p class="article-authors_authors clearfix">
<span>By&nbsp;</span>
<a href="/kenya/macharia-mwangi-3664">Macharia Mwangi</a>
</p>
</div>
</div>
</div>
<section class="article-content_summary">
<h2 class="title-small">What you need to know:</h2>
<div class="text-block">
<ul class="rte--list"><li>On Monday, while running errands, Ms Wangui heard an announcement on a local radio station about a missing boy named Liam.</li><li>Naivasha Sub County Police Commander Samuel Waweru said the suspect worked as a gardener at a home in Thika.</li></ul> </div>
</section>
<div class="articles-left-notifier" data-articles-left-notifier hidden>
<aside class="promotion-banner color-set-color-5">
<div class="promotion-banner_texts">
<h2>Thank you for reading Nation.Africa</h2>
<p data-articles-left-message></p>
<a href="/kenya/subscribe" class="default-btn">
Show plans
</a>
</div>
</aside>
</div>
<section>
<div class="text-block">
<div class="datawall-content paragraph-wrapper" data="datawall-content">
<p>At 2:45pm on Monday, Ms Zipporah Wangui walked into the Site Police Patrol base, Naivasha, within Site Estate, with a four-year-old boy.</p> </div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-1" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-1");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-1']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-1" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-1");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-1']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>She narrated how her husband’s cousin, Mr Delvin Maina, had paid them a visit on Thursday night with by the child, claiming he was his son.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>In an emotional narrative, the relative agonised about a failed relationship that led to a separation.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The cousin, who turned out to be a kidnapper, alleged that his “wife” had abandoned the child and left with household items.   </p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“Father” and “son” enjoyed a strong bond, with nothing untoward. </p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“We believed his story and offered to stay with the baby as he got his act together,’ said Ms Wangui in an interview with the Nation.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>On Saturday, the cousin failed to turn up and Ms Wangui felt something was not right.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<h2>Ransom demand</h2> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“On Sunday, my cousin, who I was meeting for the second time, failed to come back to the house and the boy kept asking where he was,” she said.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>On Monday, while running errands, Ms Wangui heard an announcement on a local radio station about a missing boy named Liam.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“The description fitted the boy in my house and I immediately reported the matter to the nearby police post... it was a very tense moment for me,” she said.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>She gave an account of what had transpired. </p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>After the report was made, it was a whirlwind of events as detectives from Nairobi and their Naivasha counterparts planned an ambush.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Meanwhile, the suspect was demanding a ransom from Liam’s parents and had received Sh40,000 by the time police cornered him.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“He was demanding Sh200,000 from the boy’s parents, but had only received the initial payment, which he used to plait his hair for camouflage.</p> </div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-2" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-2");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-2']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-2" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-2");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-2']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<h2>Arrested the suspect</h2> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>A detective involved in the operation said the kidnapper had threatened to kill the child after being exposed on social media.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“Even before Ms Wangui surrendered the baby, investigators were zeroing in on the suspect after his threatening call,” said an officer close to the investigation.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The kidnapper was lured into the police trap after he was told the baby had fallen ill and he was asked to return to his cousin’s place to take him to the hospital.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>“Police pounced on him, and the cat and mouse game was brought to a screeching halt,” said the investigator.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Naivasha Sub County Police Commander Samuel Waweru said the suspect worked as a gardener at a home in Thika, creating a bond with his victim.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>Ms Wangui’s neighbours at Site were not aware of the goings-on in their back yard, until police raided the home as they arrested the suspect.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p>The suspect was first held at the Naivasha police station before being taken to Nairobi for further questioning.</p> </div>
<div class="paragraph-wrapper" style="display: none;" data="datawall-content">
<p><em><strong>Machariamwangi2008@gmail.com</strong></em></p> </div>
</div>
</section>
<aside class="promotion-banner color-set-color-5">
<div class="promotion-banner_texts">
<h2>Nation. Empower Africa.</h2>
<p>
<strong>We come to you.</strong>
We are always looking for ways to improve our stories. Let us know what you liked and what we can improve on.
</p>
<a href="https://docs.google.com/forms/d/e/1FAIpQLSfOOJA0WUAChH42ijf4Xj1kVFuxGzwLEWYMpfHmzxqiWTh_ow/viewform?usp=pp_url&amp;entry.582792058=How%20Naivasha%20detectives%20rescued%20baby%20Liam%20from%20kidnapper" class="default-btn" target="_blank" rel="nofollow noopener">I&#39;ve got feedback!</a>
</div>
</aside>
<aside>
<ul class="social-share-list">
<li>
<div class="fb-share-button">
<a target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596" rel="noopener noreferrer" aria-label="Share on Facebook">
<svg class="icon-social-facebook" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-facebook"></use>
</svg>
</a>
</div>
</li>
<li>
<a target="_blank" class="twitter-share-button" href="https://twitter.com/intent/tweet?text=How%20Naivasha%20detectives%20rescued%20baby%20Liam%20from%20kidnapper&url=https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596" " rel="noopener noreferrer" aria-label="Share on Twitter">
<svg class="icon-social-twitter" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-twitter"></use>
</svg>
</a>
</li>
<li>
<a target="_blank" class="whatsapp-share-button" href="https://wa.me/?text=https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596" rel="noopener noreferrer" aria-label="Share on Whatsapp">
<svg class="icon-social-whatsapp" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-whatsapp"></use>
</svg>
</a>
</li>
<li>
<a target="_blank" class="email-share-button" href="mailto:?subject=How Naivasha detectives rescued baby Liam from kidnapper&body=https://nation.africa/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596" rel="noopener noreferrer" aria-label="Share via email">
<svg class="icon-social-email" aria-hidden="true" focusable="false">
<use xlink:href="#icon-social-email"></use>
</svg>
</a>
</li>
</ul>
</aside>
<div class="content-page-ad_wrap desktop">
<div id="desktop-article-ad-3" class="content-page-ad content-page-ad_desktop">
<script>
if (shouldRenderAd(false)) {
googletag.cmd.push(function () {
googletag.display("desktop-article-ad-3");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['desktop-article-ad-3']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
<div class="content-page-ad_wrap mobile">
<div id="mobile-article-ad-3" class="content-page-ad content-page-ad_mobile">
<script>
if (shouldRenderAd(true)) {
googletag.cmd.push(function () {
googletag.display("mobile-article-ad-3");
});
// Initial load (before ad refresh)
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 5000);
setInterval(function refreshAds() {
googletag.cmd.push(function adCommands() {
googletag.pubads().refresh([window.adSlots['mobile-article-ad-3']]);
});
// During ad refresh
setTimeout(() => {
const ads = document.getElementsByClassName('content-page-ad');
ads.forEach(ad => {
ad.classList.remove('center-align-ad');
ad.offsetHeight > 0 && ad.offsetHeight < 250 && ad.classList.add('center-align-ad');
});
}, 2000);
}, 90000);
}
</script>
</div>
</div>
</div>
</div>
<script>
(function() { // DON'T EDIT BELOW THIS LINE - unless "dailynation" changes on Disqus settings
var d = document, s = d.createElement('script');
s.src = 'https://dailynation.disqus.com/embed.js';
s.setAttribute('data-timestamp', +new Date());
(d.head || d.body).appendChild(s);
})();
</script>
<noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript">comments powered by Disqus.</a></noscript>
<div class="grid-container-small disqus-block is-hidden" data-disqus-comments>
<div class="col-1-1">
<h3 class="title-small">Join the discussion</h3>
<div class="disqus-block-account">
<button type="button" class="login-btn" data-log-in-disqus>
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="not-loggedIn">
<span>Login with your Nation account</span>
</ev-profile-when>
</ev-profile>
</button>
<a href="/kenya/account" class="login-btn">
<ev-profile profile="profile" service-name="my-account">
<ev-profile-when state="available">
<span class="profile-btn_name">
{{ profile.name ? "Commenting as "+profile.name : "Please add your name to your Nation profile to comment" }}
</span>
</ev-profile-when>
</ev-profile>
</a>
</div>
<div id="disqus_thread"></div>
</div>
</div>
</div>
<section class="teasers-row">
<div class="grid-container">
<div class="col-1-1 medium-col-1-2 large-col-2-3">
<section class="nested-cols">
<div class="col-1-1">
<header class="teasers-row_header">
<h2 class="section-label" style="background: #FF415D; color:#000000;">
Editor&#39;s picks
</h2>
</header>
</div>
<ul>
<li class="col-1-1 large-col-1-2">
<a href="/kenya/counties/kajiado/kajiado-court-detains-key-suspect-in-shantel-murder-3428674" aria-label="Kajiado court detains key suspect in Shantel’s murder" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3428686/landscape_ratio3x2/300/200/4c4eacd1a12ccca01086c880a1931e24/VO/suspect.jpg" data-srcset="
/resource/image/3428686/landscape_ratio3x2/300/200/4c4eacd1a12ccca01086c880a1931e24/VO/suspect.jpg 300w,
/resource/image/3428686/landscape_ratio3x2/600/400/4c4eacd1a12ccca01086c880a1931e24/WP/suspect.jpg 600w,
/resource/image/3428686/landscape_ratio3x2/900/600/4c4eacd1a12ccca01086c880a1931e24/Sk/suspect.jpg 900w,
/resource/image/3428686/landscape_ratio3x2/1200/800/4c4eacd1a12ccca01086c880a1931e24/pk/suspect.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Nativity Mutindi" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Kajiado court detains key suspect in Shantel’s murder
</h3>
<p class="teaser-image-large_paragraph text-block">
Nthuku was found in possession of the sim card that was used to demand Sh300,000 ransom.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Kajiado</span>
<span class="date">
Yesterday
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 large-col-1-2">
<a href="/kenya/news/pain-for-kitengela-family-in-kidnap-murder-of-girl-3421054" aria-label="Abduction, ransom demand and murder of girl, 8" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3421056/landscape_ratio3x2/300/200/fb83cd7dafca228e321c4faf1bcb143b/Ss/shantel.jpg" data-srcset="
/resource/image/3421056/landscape_ratio3x2/300/200/fb83cd7dafca228e321c4faf1bcb143b/Ss/shantel.jpg 300w,
/resource/image/3421056/landscape_ratio3x2/600/400/fb83cd7dafca228e321c4faf1bcb143b/Ep/shantel.jpg 600w,
/resource/image/3421056/landscape_ratio3x2/900/600/fb83cd7dafca228e321c4faf1bcb143b/Xy/shantel.jpg 900w,
/resource/image/3421056/landscape_ratio3x2/1200/800/fb83cd7dafca228e321c4faf1bcb143b/MK/shantel.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Shantel Nzembi" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
Abduction, ransom demand and murder of girl, 8
</h3>
<p class="teaser-image-large_paragraph text-block">
“My last hope to find my daughter alive was on police officers,” cries distraught mother.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">News</span>
<span class="date">
Jun 01
</span>
</aside>
</div>
</article>
</a> </li>
</ul>
</section>
</div>
<div class="col-1-1 medium-col-1-2 large-col-1-3">
<section class="teasers-row_category nested-cols">
<div class="col-1-1">
<header class="teasers-row_header">
<h2 class="section-label" style="background: #FF415D; color:#000000;">
<a href="/kenya/counties">More from Counties</a>
</h2>
</header>
<ol class="article-collection">
<li>
<a href="/kenya/counties/machakos/wrangles-rock-kalembe-ndile-burial-plans-3430578" aria-label="Wrangles rock Kalembe Ndile’s burial plans" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
Wrangles rock Kalembe Ndile’s burial plans
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Machakos</span>
<span class="date">
Just now
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/counties/turkana/the-rich-heritage-buried-in-arid-cradle-of-mankind-3431098" aria-label="The rich heritage buried in arid ‘cradle of mankind’ " class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
The rich heritage buried in arid ‘cradle of mankind’
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Turkana</span>
<span class="date">
21 min ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/counties/west-pokot/how-political-goodwill-brought-peace-inturkwel-kainuk-3430998" aria-label="How political goodwill brought peace inTurkwel, Kainuk" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
How political goodwill brought peace inTurkwel, Kainuk
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">West Pokot</span>
<span class="date">
52 min ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/counties/busia/ojaamong-appeals-for-funding-to-improve-health-3430872" aria-label="Ojaamong appeals for funding to improve health" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
Ojaamong appeals for funding to improve health
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Busia</span>
<span class="date">
1 hour ago
</span>
</aside>
</article>
</a> </li>
<li>
<a href="/kenya/counties/nairobi/nairobi-brt-system-is-for-electric-buses-only-says-ps-hinga-3429698" aria-label="Nairobi BRT system is for electric buses only - PS Hinga" class="teaser-image-none article-collection-teaser">
<article class="teaser-image-none_inner">
<h3 class="teaser-image-none_title title-extra-small">
Nairobi BRT system is for electric buses only - PS Hinga
</h3>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Nairobi</span>
<span class="date">
1 hour ago
</span>
</aside>
</article>
</a> </li>
</ol> </div>
</section> </div>
</div>
</section>
<section class="teasers-row">
<header class="teasers-row_header grid-container">
<div class="col-1-1 clearfix">
<h2 class="section-label" style="background: #FFB600; color:#000000;">
<a href="/kenya">In the headlines</a>
</h2>
<nav class="subcategories-list">
<ul>
<li>
<a href="/kenya/news" class="link-more ">
News
</a>
</li>
<li>
<a href="/kenya/counties" class="link-more ">
Counties
</a>
</li>
<li>
<a href="/kenya/business" class="link-more ">
Business
</a>
</li>
<li>
<a href="/kenya/blogs-opinion" class="link-more ">
Opinion
</a>
</li>
<li>
<a href="/kenya/sports" class="link-more ">
Sports
</a>
</li>
<li>
<a href="/kenya/life-and-style" class="link-more ">
Life &amp; Style
</a>
</li>
<li>
<a href="/kenya/newsletters" class="link-more ">
Newsletters
</a>
</li>
<li>
<a href="/kenya/audio" class="link-more ">
Audio
</a>
</li>
<li>
<a href="/kenya/puzzles" class="link-more ">
Puzzles
</a>
</li>
</ul>
</nav>
</div>
</header>
<div class="teasers-row_nested-row teasers-row_nested-row-3-col">
<ul class="grid-container">
<li class="col-1-1 large-col-1-3">
<a href="/kenya/counties/machakos/wrangles-rock-kalembe-ndile-burial-plans-3430578" aria-label="Wrangles rock Kalembe Ndile’s burial plans" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
medium-col-1-2 large-col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3430614/landscape_ratio3x2/300/200/1620cb62a308f5742a222dd1b811df80/nz/ndile-memorial.jpg" data-srcset="
/resource/image/3430614/landscape_ratio3x2/300/200/1620cb62a308f5742a222dd1b811df80/nz/ndile-memorial.jpg 300w,
/resource/image/3430614/landscape_ratio3x2/600/400/1620cb62a308f5742a222dd1b811df80/lw/ndile-memorial.jpg 600w,
/resource/image/3430614/landscape_ratio3x2/900/600/1620cb62a308f5742a222dd1b811df80/RF/ndile-memorial.jpg 900w,
/resource/image/3430614/landscape_ratio3x2/1200/800/1620cb62a308f5742a222dd1b811df80/Vh/ndile-memorial.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Kalembe Ndile" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
medium-col-1-2 large-col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
<span class="prime-teaser-label">
<svg version="1.1" viewBox="0 0 46 14">
<rect fill="#000000" width="46" height="14" />
<text transform="matrix(1 0 0 1 2 12)" fill="#FFFFFF" font-family="'Roboto'" font-weight="500" font-size="14px">PRIME</text>
</svg>
</span>
Wrangles rock Kalembe Ndile’s burial plans
</h3>
<p class="teaser-image-large_paragraph text-block">
Former Kibwezi MP&#39;s family oppose plans by MCAs to turn the event into a political affair. </p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Machakos</span>
<span class="date">
Just now
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-3">
<a href="/kenya/business/tap-into-mobile-money-market-uhuru-tells-ethiopia-3430920" aria-label="Tap into mobile money market, Uhuru tells Ethiopia" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3430922/landscape_ratio3x2/300/200/3e8409fce41048be588cd3f11ca58f45/VR/unye.jpg" data-srcset="
/resource/image/3430922/landscape_ratio3x2/300/200/3e8409fce41048be588cd3f11ca58f45/VR/unye.jpg 300w,
/resource/image/3430922/landscape_ratio3x2/600/400/3e8409fce41048be588cd3f11ca58f45/xG/unye.jpg 600w,
/resource/image/3430922/landscape_ratio3x2/900/600/3e8409fce41048be588cd3f11ca58f45/kv/unye.jpg 900w,
/resource/image/3430922/landscape_ratio3x2/1200/800/3e8409fce41048be588cd3f11ca58f45/jf/unye.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Safaricom Uhuru in Ethiopia" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Tap into mobile money market, Uhuru tells Ethiopia
</h3>
<p class="teaser-image-large_paragraph text-block">
Uhuru says move will offer the millions of Ethiopian people avenues for financial inclusion.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Business</span>
<span class="date">
3 hours ago
</span>
</aside>
</div>
</article>
</a> </li>
<li class="col-1-1 medium-col-1-2 large-col-1-3">
<a href="/kenya/counties/nairobi/nairobi-brt-system-is-for-electric-buses-only-says-ps-hinga-3429698" aria-label="Nairobi BRT system is for electric buses only - PS Hinga" class="teaser-image-large">
<article class="nested-cols">
<div class="
col-1-1
">
<figure class="lazy-img-container img-space_landscape_ratio3x2">
<img data-src="/resource/image/3431008/landscape_ratio3x2/300/200/6c832b3e6f82e7fa23a386cec141fc31/QL/brt-2.jpg" data-srcset="
/resource/image/3431008/landscape_ratio3x2/300/200/6c832b3e6f82e7fa23a386cec141fc31/QL/brt-2.jpg 300w,
/resource/image/3431008/landscape_ratio3x2/600/400/6c832b3e6f82e7fa23a386cec141fc31/uI/brt-2.jpg 600w,
/resource/image/3431008/landscape_ratio3x2/900/600/6c832b3e6f82e7fa23a386cec141fc31/Al/brt-2.jpg 900w,
/resource/image/3431008/landscape_ratio3x2/1200/800/6c832b3e6f82e7fa23a386cec141fc31/iZ/brt-2.jpg 1200w
" sizes="(min-width: 1240px) 420px, (min-width: 700px) 45vw, 90vw" alt="Thika road BRT station" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</div>
<div class="
col-1-1
teaser-image-large_summary
">
<h3 class="teaser-image-large_title title-normal">
Nairobi BRT system is for electric buses only - PS Hinga
</h3>
<p class="teaser-image-large_paragraph text-block">
PS Hinga also said the BRT system will be operated by the private sector, not government.</p>
<aside class="article-metadata ">
<span class="article-topic article-metadata_topic ">Nairobi</span>
<span class="date">
1 hour ago
</span>
</aside>
</div>
</article>
</a> </li>
</ul>
<div class="grid-container border-wrapper">
<div class="col-1-1">
<hr />
</div>
</div>
</div> </section>
<script type="text/javascript">
/* CONFIGURATION START */
var _ain = {
id: "1714",
postid: "new-3430596",
maincontent: ".article-content",
title: "How Naivasha detectives rescued baby Liam from kidnapper",
pubdate: "2021-06-09 09:00:00",
authors: "Macharia Mwangi",
sections: "Nakuru",
tags: "Prime, Crime, Investigations, Baby Liam,Kidnap,naivasha, DCI, Thika",
comments: ""
};
/* CONFIGURATION END */
(function(d,s){var sf=d.createElement(s);sf.type='text/javascript';sf.async=!0;sf.src=(('https:'==d.location.protocol)?'https://d7d3cf2e81d293050033-3dfc0615b0fd7b49143049256703bfce.ssl.cf1.rackcdn.com':'http://t.contentinsights.com')+'/stf.js';var t=d.getElementsByTagName(s)[0];t.parentNode.insertBefore(sf,t)})(document,'script')
</script></div>
<aside class="error-message-block" style="display: none;" role="alert" data-article-error>
<h1 class="title-small">Oops</h1>
<h2 class="title-normal">
We're sorry, we couldn't load the article
</h2>
<p>
If you have an Ad-blocker please disable it and reload the page or try again later.
</p>
<button type="button" class="default-btn" onclick="window.location.reload()">Reload page</button>
</aside>
<footer class="page-footer color-set-color-8" data="page-footer">
<div class="page-footer_top grid-container">
<nav role="navigation" aria-label="Site index" class="categories-nav col-1-1">
<ul class="nested-cols categories-nav_categories">
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/news" class="categories-nav_link categories-nav_title">
News
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/news/national" class="categories-nav_link ">National</a>
</li>
<li>
<a href="/kenya/news/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/news/world" class="categories-nav_link ">World</a>
</li>
<li>
<a href="/kenya/news/gender" class="categories-nav_link ">Gender</a>
</li>
<li>
<a href="/kenya/news/health" class="categories-nav_link ">Health</a>
</li>
<li>
<a href="/kenya/news/tech" class="categories-nav_link ">Tech</a>
</li>
<li>
<a href="/kenya/news/newsplex" class="categories-nav_link ">Newsplex</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/counties" class="categories-nav_link categories-nav_title">
Counties
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/counties/nairobi-metro" class="categories-nav_link ">Nairobi Metro</a>
</li>
<li>
<a href="/kenya/counties/coast" class="categories-nav_link ">Coast</a>
</li>
<li>
<a href="/kenya/counties/mountain" class="categories-nav_link ">Mountain</a>
</li>
<li>
<a href="/kenya/counties/lake-region" class="categories-nav_link ">Lake Region</a>
</li>
<li>
<a href="/kenya/counties/rift-valley" class="categories-nav_link ">Rift Valley</a>
</li>
<li>
<a href="/kenya/counties/northern" class="categories-nav_link ">Northern</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/business" class="categories-nav_link categories-nav_title">
Business
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/business/companies" class="categories-nav_link ">Companies</a>
</li>
<li>
<a href="/kenya/business/finance-and-markets" class="categories-nav_link ">Finance and Markets</a>
</li>
<li>
<a href="/kenya/business/seeds-of-gold" class="categories-nav_link ">Seeds of Gold</a>
</li>
<li>
<a href="/kenya/business/enterprise" class="categories-nav_link ">Enterprise</a>
</li>
<li>
<a href="/kenya/business/shillings-sense" class="categories-nav_link ">Shillings &amp; Sense</a>
</li>
<li>
<a href="/kenya/business/leadership" class="categories-nav_link ">Leadership</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/blogs-opinion" class="categories-nav_link categories-nav_title">
Opinion
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/blogs-opinion/editorials" class="categories-nav_link ">Editorials</a>
</li>
<li>
<a href="/kenya/blogs-opinion/opinion" class="categories-nav_link ">Our Columnists</a>
</li>
<li>
<a href="/kenya/blogs-opinion/blogs" class="categories-nav_link ">Guest Blogs</a>
</li>
<li>
<a href="/kenya/blogs-opinion/letters" class="categories-nav_link ">Letters to the Editor</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cutting-edge" class="categories-nav_link ">Cutting Edge</a>
</li>
<li>
<a href="/kenya/blogs-opinion/cartoons" class="categories-nav_link ">Cartoons</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/sports" class="categories-nav_link categories-nav_title">
Sports
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/sports/football" class="categories-nav_link ">Football</a>
</li>
<li>
<a href="/kenya/sports/athletics" class="categories-nav_link ">Athletics</a>
</li>
<li>
<a href="/kenya/sports/rugby" class="categories-nav_link ">Rugby</a>
</li>
<li>
<a href="/kenya/sports/africa" class="categories-nav_link ">Africa</a>
</li>
<li>
<a href="/kenya/sports/talkup" class="categories-nav_link ">TalkUP!</a>
</li>
<li>
<a href="/kenya/sports/other-sports" class="categories-nav_link ">Other Sports</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/life-and-style" class="categories-nav_link categories-nav_title">
Life &amp; Style
</a>
<ul class="categories-nav_sub">
<li>
<a href="/kenya/life-and-style/culture" class="categories-nav_link ">Culture</a>
</li>
<li>
<a href="/kenya/life-and-style/family" class="categories-nav_link ">Family</a>
</li>
<li>
<a href="/kenya/life-and-style/relationships" class="categories-nav_link ">Relationships</a>
</li>
<li>
<a href="/kenya/life-and-style/art-books" class="categories-nav_link ">Art &amp; Books</a>
</li>
<li>
<a href="/kenya/life-and-style/travel" class="categories-nav_link ">Travel</a>
</li>
<li>
<a href="/kenya/life-and-style/wellness" class="categories-nav_link ">Wellness</a>
</li>
</ul>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/newsletters" class="categories-nav_link categories-nav_title">
Newsletters
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/audio" class="categories-nav_link categories-nav_title">
Audio
</a>
</li>
<li class="col-1-1 medium-col-1-3 large-col-1-6 categories-nav_category ">
<a href="/kenya/puzzles" class="categories-nav_link categories-nav_title">
Puzzles
</a>
</li>
</ul>
</nav>
<nav role="navigation" aria-label="Site Information Navigation" class="page-footer_metanav col-1-2 medium-col-2-3">
<ul class="clearfix">
<li><a href="/kenya/empower" target="_blank">Empower Africa</a></li>
<li><a href="/kenya/contact-us-294088" target="_blank">Contact Us</a></li>
<li><a href="/kenya/frequently-asked-questions-303716" target="_blank">Frequently asked questions</a></li>
<li><a href="/kenya/nmg-privacy-policy-303724" target="_blank">NMG Privacy Policy</a></li>
<li><a href="/kenya/terms-and-conditions" target="_blank">Terms and Conditions of Use</a></li>
<li><a href="/kenya/our-blog-rules-549010" target="_blank">Our Blog Rules</a></li>
</ul>
</nav>
<p class="page-footer_copyright col-1-1 medium-col-1-3">
<span class="page-footer_copyright-year">Nation Media Group &copy; 2021</span> Nation Part of <a href="https://www.nationmedia.com/" rel="noreferrer">Nation Media Group</a>
</p>
</div>
<figure class="page-footer_decoration">
<img data-src="/resource/crblob/1337610/4ffe0a0e8c1ddb5abcac8c8d4862e60e/footer-decoration-svg-data.svg" alt="Decoration" class="lazy-img" data-lazy-img="true" loading="lazy" />
</figure>
</footer></section>
<div class="evolok-widgets">
<ev-paywall group-name="default" redirect=false></ev-paywall>
<ev-paywall-notifier></ev-paywall-notifier>
<div style="visibility: hidden; height: 0px; overflow: hidden; position: absolute;">
<ev-login ev-modal id="login-widget" title="Login" auth-scheme-name="default" service-name="login" show-labels="false" show-social="true" social-networks="['facebook', 'google']" auto-register="false" auto-populate="false" forgot-password-service="reset-password"></ev-login>
<ev-registration ev-modal id="registration-widget" title="Sign up for free" auth-scheme-name="default" service-name="registration" show-labels="false" show-social="true" social-networks="['facebook', 'google']" auto-login="true" auto-register="false" auto-populate="true"></ev-registration>
<ev-social-registration id="socialRegistration" ev-modal title="Almost there!" description="Would you like to receive marketing updates and offers from Nation? You may opt out anytime." auth-scheme-name="default" service-name="default" auto-register="false" auto-populate="true"></ev-social-registration>
<div id="registration-welcome" ev-modal>
<div class="registration-welcome">
<div class="ev-widget-header">
<p>Welcome!</p>
</div>
<div class="ev-widget-body">
<div class="ev-text-wrapper">
<div class="ev-title-wrapper">
<h3>You're all set to enjoy unlimited Prime content.</h3>
</div>
</div>
<div class="ev-button-wrapper">
<div>
<button class="btn">
Start reading
</button>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<script>
var evolokParams = {
articleId: '3430596',
section: 'Counties',
category: 'Nakuru',
authors: 'Macharia Mwangi',
site: 'Nation',
tags: 'Prime,Crime,Investigations',
contentType: 'article',
publishDate: '2021-06-09T06:00:00Z',
premium: true
};
var evolokInitParams = {
url: 'https://nmg.evolok.net',
enableSSOMode: false,
enableSeamlessMode: false,
cookieDomain: 'nation.africa',
socialLoginRedirectUri: 'https://nation.africa/kenya/account',
homepageUrl: '/kenya',
termsAndConditionsUrl: '/kenya/terms-and-conditions',
faqUrl: '/kenya/frequently-asked-questions-303716',
}
</script>
<script>
window.polyfillsForOldBrowsersLoaded = false;
if ("Promise" in window &&
!!window.HTMLPictureElement &&
'objectFit' in document.documentElement.style) {
window.polyfillsForOldBrowsersLoaded = true;
} else {
var f = document.getElementsByTagName('script')[0];
var j = document.createElement('script');
j.async = true;
j.src = "/resource/themes/nation-2020/js/polyfills-for-old-browsers.ts-491110-45.js";
f.parentNode.insertBefore(j,f);
}
</script>
<script data-evolok-script="true" data-src="https://scripts.nation.africa/ev-widgets-v3.11.1.min.js" defer></script>
<link rel="stylesheet" href="https://scripts.nation.africa/css/ev-widgets.min.css ">
<script src="/resource/themes/nation-2020/js/nation-2020.ts-491108-121.js" defer></script>
<script id="doubleClickJS" src="https://securepubads.g.doubleclick.net/tag/js/gpt.js" async defer></script>
<!--[if IE 9]> <script>
var dcScript = document.getElementById("doubleClickJS");
dcScript.parentNode.removeChild(dcScript);
</script> <![endif]-->
<script type="text/javascript">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</script><script type='text/javascript'>
var isVideoPage = false;
var trackVideo = isVideoPage || window.hasEmbeddedVideo === true;
(function() {
var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
/** CONFIGURATION START **/
_sf_async_config.uid = 63208;
_sf_async_config.domain = 'nation.africa';
_sf_async_config.flickerControl = false;
_sf_async_config.useCanonical = true;
_sf_async_config.useCanonicalDomain = true;
_sf_async_config.sections = 'Counties,Counties - Nakuru';
_sf_async_config.authors ='Macharia Mwangi';
/** CONFIGURATION END **/
function loadChartbeat() {
var chartbeatScript = document.createElement('script');
chartbeatScript.type = 'text/javascript';
chartbeatScript.async = true;
chartbeatScript.src = '//static.chartbeat.com/js/chartbeat.js';
var n = document.getElementsByTagName('script')[0];
n.parentNode.insertBefore(chartbeatScript, n);
}
function loadChartbeatWithVideoTracking() {
// YouTube's API script, required for Chartbeat's video engagement tracking -->
var youtubeScript = document.createElement('script');
youtubeScript.type = 'text/javascript';
youtubeScript.async = true;
youtubeScript.src = '//www.youtube.com/iframe_api';
// Chartbeat Video script
var chartbeatVideoScript = document.createElement('script');
chartbeatVideoScript.type = 'text/javascript';
chartbeatVideoScript.async = true;
chartbeatVideoScript.src = '//static.chartbeat.com/js/chartbeat_video.js';
// Include both scripts
var n = document.getElementsByTagName('script')[0];
n.parentNode.insertBefore(youtubeScript, n);
n.parentNode.insertBefore(chartbeatVideoScript, n);
}
if (trackVideo) {
/** TELL CHARTBEAT TO AUTODETECT YOUTUBE VIDEOS **/
var _cbv = window._cbv || (window._cbv = []);
_cbv.push(['autoDetectYouTubeIframes']);
loadChartbeatWithVideoTracking();
} else {
loadChartbeat();
}
})();
</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script><script type="text/javascript">
_atrk_opts = { atrk_acct:"7CIsk1acBb00OC", domain:"nation.africa",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://certify-js.alexametrics.com/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://certify.alexametrics.com/atrk.gif?account=7CIsk1acBb00OC" style="display:none" height="1" width="1" alt="" /></noscript>
<script type="text/javascript">
function GaAccountData(webPropertyId, domainName) {
this.webPropertyId = webPropertyId;
this.domainName = domainName;
}
function GaPageviewData(disableAdFeaturesPlugin, contentId, contentType, navigationPath, pageUrl, authors, pubDate, tags, queryParameter, query, userSegments) {
this.contentId = contentId;
this.contentType = contentType;
this.navigationPath = navigationPath;
this.pageUrl = pageUrl;
this.authors = authors;
this.pubDate = pubDate;
this.tags = tags;
this.queryParameter = queryParameter;
this.query = query;
this.userSegments = userSegments;
this.disableAdvertisingFeaturesPlugin = typeof disableAdFeaturesPlugin !== 'undefined' ? disableAdFeaturesPlugin : false;
}
function GaEventData(category, action, name, value) {
this.category = category;
this.action = action;
this.name = name;
this.value = value;
}
function setupGa(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
//set Account
if (trackerName && trackerName.length > 0) {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName, {'name': trackerName});
} else {
ga('create', gaAccountData.webPropertyId, gaAccountData.domainName);
}
ga(t.concat('set'), 'anonymizeIp', true);
if (!gaPageviewData.disableAdvertisingFeaturesPlugin) {
ga(t.concat('require'), 'displayfeatures');
}
//set custom vars
ga(t.concat('set'), 'dimension1', gaPageviewData.contentId);
ga(t.concat('set'), 'dimension2', gaPageviewData.contentType);
ga(t.concat('set'), 'dimension3', gaPageviewData.navigationPath);
ga(t.concat('set'), 'dimension4', gaPageviewData.userSegments);
ga(t.concat('set'), 'dimension5', gaPageviewData.authors);
ga(t.concat('set'), 'dimension6', gaPageviewData.pubDate);
ga(t.concat('set'), 'dimension7', gaPageviewData.tags);
ga(t.concat('set'), 'dimension8', 'Prime');
}
function setGaCustomDimension(name, content, trackerName) {
var t = _gaTrackerPrefix(trackerName);
ga(t.concat('set'), name, content);
}
function gaTrackPageview(ga, gaAccountData, gaPageviewData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
var query = "";
if (gaPageviewData.query && gaPageviewData.queryParameter) {
query = "?" + gaPageviewData.queryParameter + "=" + encodeURIComponent(gaPageviewData.query);
}
ga(t.concat('send'), 'pageview', gaPageviewData.pageUrl + query);
}
function gaTrackEvent(ga, gaAccountData, gaPageviewData, gaEventData, trackerName) {
var t = _gaTrackerPrefix(trackerName);
ga(t.concat('send'), 'event', gaEventData.category, gaEventData.action, gaEventData.name, gaEventData.value);
}
function _gaTrackerPrefix(trackerName) {
return (trackerName && trackerName.length > 0)
? trackerName.concat('.')
: '';
}
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
var gaAccountData = new GaAccountData("UA-1030601-83", "nation.africa");
var gaPageData = new GaPageviewData(
false,
"3430596",
"CMArticle",
"31772_522_1134",
"/kenya/counties/nakuru/how-naivasha-detectives-rescued-baby-liam-3430596"
,"Macharia Mwangi",
"09-06-2021",
"Prime, Crime, Investigations"
);
setupGa(ga, gaAccountData, gaPageData);
function sendGaTrackPageview() {
gaTrackPageview(ga, gaAccountData, gaPageData);
}
</script>
<script type="text/javascript">
window._taboola = window._taboola || [];
_taboola.push({flush: true});
</script><script type="text/javascript">(function(){window['__CF$cv$params']={r:'65c9f2e1ed230684',m:'dd5a768c0cd7826cf161e59743a4c316940870ce-1623237396-1800-AUNNXTidEUdeGZZA+PpctsRCifSZeG9ipAwtqmZFxMpMIBtydN6j+S6SoGer1Fw5qGwxApLMsUwSkvHIjYKXnfKWTIh6h9xKYLD9INhjkFglsgRgHEfWfYK8eODecrETeqQYN+cjVyStWUFwN1E79LuwI+p9N/ltRizR4NzrS8kOIeAySQaHgbxVVvg2dxDMNl0sON92QQXsys3DtQlOzLU=',s:[0xe754d40c50,0xe370fa72f4],}})();</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"65c9f2e1ed230684","token":"0da52c244fc64e7c8de980e5d83e0a85","version":"2021.5.2","si":10}'></script>
</body></html>
